WordPress.org

Ready to get started?Download WordPress

Forums

MyCurator
[resolved] Comments Metadata dissaperared (5 posts)

  1. xorbal
    Member
    Posted 1 year ago #

    Hello, I just posted my first curated post with MyCurator and the Comments metadata disappeared from the post. I know there are no comments to the post yet but it should say 'No Comments', and instead it's blank. Am I missing something here? Maybe on the Options page?

    Thanks.

    http://wordpress.org/extend/plugins/mycurator/

  2. mtilly
    Member
    Plugin Author

    Posted 1 year ago #

    Is this occurring on the single post page or on the main blog page? Could post some links to your site where you see the problem?

  3. xorbal
    Member
    Posted 1 year ago #

    It's only happening on the single post page and on the mail blog page but only for that specific post.

    You can see it here:

    http://www.agequisite.com/blog/

    It's the 3rd post entitled "Bangs are Cheaper than Botox"

  4. mtilly
    Member
    Plugin Author

    Posted 1 year ago #

    Yes, I see it. Once you have made a MyCurator post 'live' it looks to WordPress like any other post. You can edit it and see that what you see in the editor is what you get on the blog. This leads me to believe it is probably something to do with your comment settings. If comments are closed, the comment tag usually won't show up in the metadata if there are no comments to view.

    One possibility is that you have your Settings for Discussion set to only allow comments for a certain amount of days. The post date of a post that MyCurator creates is the day it was posted to your training page, Not the day you actually posted it to your live blog. So maybe the post is too old for comments, especially if you only have them open for a short time?

    Another possibility is that in your settings a post is normally not open for comment unless you specifically set it. MyCurator would not set this flag when it makes a post live. You could check this by editing the post and looking at the Discussions widget box (you may have to activate it with the Screen Options in the upper right of the page).

    I'm not sure if you use standard WordPress comments or a plugin. If a plugin, it may look for certain conditions to be set before allowing comments?

  5. xorbal
    Member
    Posted 1 year ago #

    Thanks for your help! As you pointed out I hadn't checked the Discussion button to allow comments for that post. Once I allowed comments, the 'No Comments' tag came back on. Interestingly, the 'allow comments' check button now shows up under the Saved Page.

    Anyway, problem solved! Thanks!!

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic

Tags

No tags yet.