WordPress.org

Ready to get started?Download WordPress

Forums

My Custom Widgets
Debug on - "Uninitialized string offset" (2 posts)

  1. gilu
    Member
    Posted 2 years ago #

    Hi there!

    I've enabled the debug mode in WordPress, just for fun, I thought.
    Then I saw hundreds of these messages:

    Notice: Uninitialized string offset: 0 in /home/.../wp-content/plugins/mycustomwidget/my_custom_widget_functions.php on line 769
    
    Notice: Uninitialized string offset: 0 in /home/.../wp-content/plugins/mycustomwidget/my_custom_widget_functions.php on line 771
    
    Notice: Uninitialized string offset: 0 in /home/.../wp-content/plugins/mycustomwidget/my_custom_widget_functions.php on line 773
    
    Notice: Uninitialized string offset: 0 in /home/.../wp-content/plugins/mycustomwidget/my_custom_widget_functions.php on line 775

    Any ideas?

    Thanks!

    http://wordpress.org/extend/plugins/mycustomwidget/

  2. Derwood
    Member
    Posted 2 years ago #

    Just upgraded my server to PHP 5.4.3 and found the following in my errors log:

    [Mon Jun 11 19:03:31 2012] [error] [client 66.249.71.133] PHP Warning: Illegal string offset 'before_widget' in /www/paspitablog/wp-content/plugins/mycustomwidget/my_custom_widget_functions.php on line 769
    [Mon Jun 11 19:03:31 2012] [error] [client ] PHP Warning: Illegal string offset 'after_widget' in /www/wp-content/plugins/mycustomwidget/my_custom_widget_functions.php on line 771
    [Mon Jun 11 19:03:31 2012] [error] [client ] PHP Warning: Illegal string offset 'before_title' in /www/wp-content/plugins/mycustomwidget/my_custom_widget_functions.php on line 773
    [Mon Jun 11 19:03:31 2012] [error] [client ] PHP Warning: Illegal string offset 'after_title' in /www/wp-content/plugins/mycustomwidget/my_custom_widget_functions.php on line 775

    And I don't have debug turned on.. This all started *after* going to PHP 5.4.3.

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic