WordPress.org

Ready to get started?Download WordPress

Forums

My Calendar
[resolved] iCal .ics not picking up date (11 posts)

  1. maximan
    Member
    Posted 1 year ago #

    Just installed v2.0 and found what looks like a bug. Clicking iCal downloads an .ics file but when this file is added to iCal (or in my case BusyCal) it adds a (null) on 12/31/1969. Below are example urls for each link. You can see v2.0 is not picking up the date:

    version 2.0
    http://example.com?vcal=mc_2

    Here is the url of the same iCal link in v1.11.3:
    http://example.com?vcal=mc_2012-11-07_2

    http://wordpress.org/extend/plugins/my-calendar/

  2. Joe Dolson
    Member
    Plugin Author

    Posted 1 year ago #

    The URL is right; but I may have missed something in the iCal generation. The URL format was changed in version 2.0. Thanks for noting this!

  3. Joe Dolson
    Member
    Plugin Author

    Posted 1 year ago #

    Bug identified and fixed; I'll get this out soon.

  4. maximan
    Member
    Posted 1 year ago #

    I installed v2.02 but it seems there's still a bug re the .ics file. For example, I have an event with a begin time of 6:30 p.m. and end 7:30 p.m. but the iCal export ics file shows 2 hours earlier, i.e. 4:30 begin and 5:30 end.

  5. Joe Dolson
    Member
    Plugin Author

    Posted 1 year ago #

    iCal shows times at UTC, not in your timezone; are you in UTC +2?

  6. maximan
    Member
    Posted 1 year ago #

    WP Settings/General is set at UTC-4 and My Calendar Edit Event is set at GMT-4 (Universal Coordinated Time is the same Greenwich Mean Time but WP uses UTC and My Calendar uses GMT). Regardless, the fact is that with v1.11.3 the iCal export was correct whereas v2.x iCal export .ics file is off by 2 hrs.

  7. maximan
    Member
    Posted 1 year ago #

    The issue of 2hr time error remains in v2.0.3. For example, an .ics file from an event with start time of 6:30pm and end time of 7:30pm when viewed in the Finder Preview (i.e. not after imported into iCal) shows start time of 4:30pm and end time of 5:30pm. Surely the ics file should match the event.

  8. Joe Dolson
    Member
    Plugin Author

    Posted 1 year ago #

    So, I just did some testing, and I'm really not sure what's going on for you. What the iCal output time should show (and does in my own test installations), is the UTC time of the event with a UTC marker (Z), indicating that the time is being expressed at UTC.

    In my installation, the time is expressed with the correct offset from my current time (5 hours), and then is imported successfully into Google Calendar at my local time.

    What is very strange to me is the fact that your WP settings are at UTC-4 but your ics is coming up off by 2 hours. Maybe it's an iCal thing; I'll have to explore that.

  9. maximan
    Member
    Posted 1 year ago #

    Here's the dump from ics:

    DTSTAMP:20121107T223000Z
    ORGANIZER;CN=MAILTO:example.com
    DTSTART:20121107T223000Z
    DTEND:20121107T233000Z

    So, yes, it's showing Z and the ics file as seen in OSX 1.8 is the typical iCal icon with the date and time but the time if -2hrs from the time as set in Event. When imported it also is off by 2hrs. As I said earlier, the exported ics should be identical to the Event time regardless of zone setting.

    I don't know if this helps narrow down the possible bug but it's Interesting to note the ics icon generated by 1.11.3 reflects the fact that I'm using BusyCal whereas that generated by 2.0.3 has the typical iCal icon. Here's an extract from the ics from v1.11.3:

    [time] => 6:30 pm
    [endtime] => 7:30 pm
    [usertime] => 6:30 pm
    [endusertime] => 7:30 pm
    [ical_start] => 20121107T223000
    [ical_end] => 20121107T233000

  10. Joe Dolson
    Member
    Plugin Author

    Posted 1 year ago #

    Just released 2.0.4, added an option to set your iCal options to entered time. This should work fine as long as your users are actually in your time zone. You'll need to change the default setting on your settings page.

  11. maximan
    Member
    Posted 1 year ago #

    Yes, unchecking UTC fixed the problem. Great response. Many thanks.

    BTW, I didn't mention previously that I have set iCal timezone to "floating" because I found it less confusing as I travelled, otherwise appointments were changing (as designed) but this caused problems.

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic