WordPress.org

Ready to get started?Download WordPress

Forums

Mute Screamer
Causes WP error (2 posts)

  1. Doug Nix
    Member
    Posted 3 years ago #

    When I first installed Mute Screamer it seemed to activate OK. I went on to make settings and save them. Following that I made some edits to my active theme and the site crashed, leaving me with a generic 404 at my URL and 'A WordPress error occurred' from my login screen.

    Deleting the plugin folder from wp-content/plugins restored the site to operation.

    I tried reinstalling the plugin from a fresh download and had the same site crash occur.

    I had a look at the DB and noticed that there were a couple of entries in the intrusions table. I deleted the table from the DB. I am reluctant to reinstall the plugin to test it again.

    There may be some interaction between another plugin 'Login Logger', 'Login Lockdown' and Mute Screamer. I have tried various combinations of these plugins, but it seems the problem is localized to Mute Screamer.

  2. ampt
    Member
    Plugin Author

    Posted 3 years ago #

    I tried Mute Screamer with Login Lockdown and Login Logger, there doesn't appear to be any problems running these plugins alongside Mute Screamer.

    Were you using the theme editor in the WordPress admin?

    If you were editing your theme with the theme editor in the admin and you have enabled Mute Screamer in the admin and also enabled banning then you will most likely get banned when trying to save/edit your theme files.

    You have a few options to get around this:

    You can disable Mute Screamer in the WordPress admin while you are editing your theme files and turn it back on when you are finished; or

    You can disable banning while you are editing your theme files and turn it back on when you are finished; or

    You can add the fields causing you to get banned by adding them to the exceptions list on the Mute Screamer settings page. So in this case you would add these fields to the exceptions list:

    POST._wp_http_referer
    POST.file
    POST.newcontent
    REQUEST._wp_http_referer
    REQUEST.file
    REQUEST.newcontent
    GET.file

    Now Mute Screamer will totally ignore these fields anytime it sees them in a request.

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic