WordPress.org

Ready to get started?Download WordPress

Forums

Musopress Discography
[resolved] Album pages not found (9 posts)

  1. Mr. K
    Member
    Posted 2 years ago #

    I love the styling of your plugin but for some reason can't seem to get the album pages I have created to display. Any suggestions?

    Below is a link to the test page. It displays a series of studio albums which I created by pressing the ADD NEW ALBUM buttom. The problem is when I click on any of these albums to read more information/track list all I get is: "Not Found: Apologies, but the page you requested could not be found. Perhaps searching will help."

    Any help or advice would be so much appreciated.

    http://cillablack.com/blog/discography/

    http://wordpress.org/extend/plugins/musopress-discography/

  2. eschnack
    Member
    Plugin Author

    Posted 2 years ago #

    Hi, just go to your permalinks settings page and press "Save". That should fix it.

  3. Mr. K
    Member
    Posted 2 years ago #

    I read this suggestion for another reported problem and actually decided to try it already. Sadly it had no effect.

    Do you by chance have any other suggestions?

  4. eschnack
    Member
    Plugin Author

    Posted 2 years ago #

    That's weird...could you tell me what plugins you're using`? Are you using any sort of caching plugin by any chance?

  5. Mr. K
    Member
    Posted 2 years ago #

    Hi there. I think I tested it out prior to installing most of these plugins as the wordpress had only just been installed.

    But I have AddThis Social Bookmarking Widget, Akismet, Artiss Code Embed, Catablog, Discography (an alternate I was trialing as yours would not function), Facebook Fan Box, GD Star Rating, MP Spam Be Gone, Musopress Discography, Network Publisher, SI Captcha Anti-Spam and Universal Post Manager.

    I hope there is a simple explanation here as it looked such a great plugin and as I run a number of music fan sites would be nice to have it.

    Thanks for your time and input!

  6. eschnack
    Member
    Plugin Author

    Posted 2 years ago #

    Hmmm, is the other Discography plugin still activated? Could be there's some conflict there.

    Also, can you change your permalinks to 'Default' (?=123) and see if it still happens? That would at least help in narrowing down the problem...

  7. Mr. K
    Member
    Posted 2 years ago #

    I did as you said and it appears that the problem was to do with permalinks settings.

    If I change these from default to "MONTH and NAME" I get the page not found error. Do you have any suggestions of what I can do to fix things as I'd prefer to run my blog with the MONTH and NAME showing?

    Thank you again for the advice!

  8. eschnack
    Member
    Plugin Author

    Posted 2 years ago #

    Ok, then for some reason the rewrite isn't working. Can you email me at eschnack at gmail dot com? It'll be easier for me to respond to you quickly and get to the bottom of this...

  9. eschnack
    Member
    Plugin Author

    Posted 2 years ago #

    Just for future reference for anybody reading this thread, the problem was with the theme. It was creating its own custom post types and was using flush_rewrite_rules() after every register_post function. See http://wordpress.stackexchange.com/questions/3122/wordpress-custom-post-types-breaks-permalink-on-theme-reinstall

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic