WordPress.org

Ready to get started?Download WordPress

Forums

Multisite Language Switcher
[resolved] blogs are not really "inter-connected" (4 posts)

  1. akedv
    Member
    Posted 2 years ago #

    hi there,

    i just installed wordpress multisite with 2 blogs, the first (german) in root, the second (english) in /en.

    i activated the mls in the network admin and saved the configuration in both logs, but the strange part is:

    in wp-admin Settings > Multisite Language Switcher on the english blog i see both blogs listed on top, this looks like this:

    blogname 1 / Deutsch | blogname 2 / English

    so i can switch to the settings in the german blog, BUT in the german blog only the german part shows up, looks like this:

    / Deutsch

    no blog name no link, nothing, and from the german blog i can't connect the german pages/categories/... to the english ones, because only the german pages/categories/... are listed in the drop down field!

    i do can connect them from the english blog though, but creating/editing a page in the german blog gives me this error message:

    Fatal error: Call to a member function get_language() on a non-object in /home/.sites/143/site1518/web/wp-content/plugins/multisite-language-switcher/includes/MslsMain.php on line 65

    and can't be saved! i have to deactivate the mls plugin on the german blog first to edit existing pages or create new ones, which is neither nice nor practicable.

    There is only one user (admin), and i am using the suffusion theme and the following plugins:

    Contact Form Plugin
    Cimy User Extra Fields
    Hotfix
    Jigoshop
    Jigoshop Custom Payment Gateway
    Jigoshop Deutsch (de_DE) (only the german blog)
    Simple Lightbox
    Suffusion Commerce Pack
    WP Native Dashboard

    i hope you can help me there i am very despered right now, i was already searching all the posts here for this "bug" and spending some more hours on google to no avail

    greetings

    http://wordpress.org/extend/plugins/multisite-language-switcher/

  2. realloc
    Member
    Plugin Author

    Posted 2 years ago #

    The admin-user has the same email-address in both blogs? Please check it in /wp-admin/network/site-settings.php?id=1 and in the settings of the other blog. This is a known issue which is allready corrected in the trunk of the next version.

  3. akedv
    Member
    Posted 2 years ago #

    damn you're right, there was a different email address! works like a charm now, thx a alot!!! where can i donate using paypal?

  4. realloc
    Member
    Plugin Author

    Posted 2 years ago #

    Very good! The "Donate"-link of this plugin BTW points to http://www.greenpeace.org/international/ if you'd like to make a donation.

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic