WordPress.org

Ready to get started?Download WordPress

Forums

Multisite Language Switcher
[resolved] Another newbee question (21 posts)

  1. juliejcdesign
    Member
    Posted 1 year ago #

    I installed multisite language switcher plugin. I have a website with the main adress .com being the english version and the french version is on .com/fr

    When I create a page for exemple About me page, I would like the switcher to switch me to the french version of the about me page when I click on the link but instead it always bring me back to the root mywebsite.com I tried in the little menu on the right to select the french page with the drop down menu but it does not seem to work. Is there anything I am doing wrong and is there any video I could watch to leanr more about how to use the plugin.

    http://wordpress.org/extend/plugins/multisite-language-switcher/

  2. realloc
    Member
    Plugin Author

    Posted 1 year ago #

    Let me try to understand what's going on. All pages (the English and French one) are published? They are not just drafts?

    And in your blogs there is no message that you must finish the installation of the plugin?

    Cheers,
    Dennis.

  3. juliejcdesign
    Member
    Posted 1 year ago #

    Yes, my pages are published english and french and there is no message that I must finish the installation of the plug in.

  4. realloc
    Member
    Plugin Author

    Posted 1 year ago #

    You have an URL so I can see this?

  5. juliejcdesign
    Member
    Posted 1 year ago #

    Should I write the adress in the blank space on top instead of using the drop down menu ?

  6. juliejcdesign
    Member
    Posted 1 year ago #

    I will have an url, give me around 15minutes. It is for now on maintenance mode, I will switch it off for an hour or so

  7. juliejcdesign
    Member
    Posted 1 year ago #

    The url is http://www.juliecloutier.com You will see that the link to the french in the left sidebar always bring us back to the english home page.

  8. realloc
    Member
    Plugin Author

    Posted 1 year ago #

    OK ... this is the standard if there are no relations created. You said that you had problems to use the meta_box in "Edit post"? And you saved it?

  9. juliejcdesign
    Member
    Posted 1 year ago #

    Well when I go to my post or page, on the top right corner there is a box with a drop down menu Called Multisite Language switcher, when I try to select the other language version of the same post or page, it won't save it. See the image here : http://www.juliecloutier.com/wp_bug/multilanguage.jpg

  10. realloc
    Member
    Plugin Author

    Posted 1 year ago #

    Are you sure that you made the setup and that you have the latest version? It's quite strange to see the French flag where should be the American flag visible.

  11. realloc
    Member
    Plugin Author

    Posted 1 year ago #

    If you want you can send me a login so I can have a look what's going wrong ...

  12. juliejcdesign
    Member
    Posted 1 year ago #

    Thank you, it is generous of you. How do I do that, what is your e-mail ?

  13. realloc
    Member
    Plugin Author

    Posted 1 year ago #

    My mail-address is re[at]lloc[dot]de.

  14. juliejcdesign
    Member
    Posted 1 year ago #

    Maybe the trouble is from my network ?

  15. juliejcdesign
    Member
    Posted 1 year ago #

    Did you received the login I sent you ?

  16. realloc
    Member
    Plugin Author

    Posted 1 year ago #

    It is important to control for every blog twice the languages in General settings. ;)

  17. juliejcdesign
    Member
    Posted 1 year ago #

    Wow thank you ! You have the best plugins for multi-language.

  18. juliejcdesign
    Member
    Posted 1 year ago #

    Hi again, re-opening this tread again because you are so great with supporting your plugin and I thought you might see this message here for sure if I re-opened an existing thread between the 2 of us.

    I did another website using your multisite language switcher plugin and ran into another problem.

    The site is at http://www.cliniquedac.com (password protected : artistry) the french version is at http://www.cliniquedac.com/fr (password : artisterie)

    I am using multisite language switcher in the top nabv to switch from one language to the other, this works well.

    The problem that I have I when I want to assign a page to another it does not work. For example, I go to the english Contact page at http://www.cliniquedac.com/contact and I try to assign to it the french version http://www.cliniquedac.com/fr/contact but when I click on Update, it won't show and it does not work.

    Any idea what is happening, that has never happened to me before and I used the plugin more then once.

    Thank you.

  19. juliejcdesign
    Member
    Posted 1 year ago #

    You know what, as I re-read what I wrote before in this thread, I realise I have the same problem I had then, but one thing I am almost sure of is that I did set-up both blogs correctly, so the problem seem to be the same but I doubt the reason for it is. I will double check, just in case.

    O, I think it's because I did not switch my second blog to FRench as a language for wordpress. Both of my blog are running on an english version of wordpress, so even though I did translate the content, I guess because I did not switch the language of wordpress the plugin does not know where to find the other pages ?

  20. realloc
    Member
    Plugin Author

    Posted 1 year ago #

    You're right. The Multisite Language Switcher has the limitation that you must set up different languages. I'm thinking about to change this but I'm not sure what are the possible side-effects.

    Cheers,
    Dennis.

  21. juliejcdesign
    Member
    Posted 1 year ago #

    Yes, it is working now. Thank you. Your plugin is such a great tool.

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic