WordPress.org

Ready to get started?Download WordPress

Forums

Multiple Galleries
Check boxes not showing up (4 posts)

  1. CircleReader
    Member
    Posted 3 years ago #

    Just installed this on 3.0.1, and the check boxes do not appear on the media management window as in the screen shots at http://konstruktors.com/projects/wordpress-plugins/multiple-galleries/

  2. lipsk
    Member
    Posted 3 years ago #

    Same problem here.
    There's only the multiple-galleries plugin activated on my site.

    I cheched the error console on firefox and it showed:

    "editor is null
    on line 24 of plugins/multiple-galleries/multiple-galleries.js?ver=1 "

    And on IE 8:

    "Message: 'editor.selection' is null or is not an object
    Line: 24
    Character: 2
    Code: 0
    URI: .../wp-content/plugins/multiple-galleries/multiple-galleries.js?ver=1"

  3. lipsk
    Member
    Posted 3 years ago #

    I played with the javascript code and managed to make the checkboxes appear on firefox. But then the error migrated to the line 54.

  4. lipsk
    Member
    Posted 3 years ago #

    I found it out.

    The checkboxes don't show when you're trying to add the gallery from the HTML editor. They show fine when you're using the Visual editor.

    Just add and update each multiple gallery from the Visual.

    OR, if you want, modify the javascript checking both if the object editor is null (for firefox) and if editor.selection is null (for IE) before each call to them. This modification made it work on HTML editor too.

    The problem is: javascript is trying to set editor = w.tinymce.EditorManager.activeEditor, but this is null on HTML editor.

    I hope I wrote it understandable. Sorry for the bad English.

    This plugin is great. Authors just don't have the patience to look for the attachment id on Media Library. This plugin will made it much easier for them.

    Thank you Kaspars Dambis

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic