WordPress.org

Ready to get started?Download WordPress

Forums

Multilingual Press
[resolved] How to configure redirect of the main page? (list of posts) (12 posts)

  1. pedro.prieto-martin
    Member
    Posted 1 year ago #

    How to configure the redirect link of the main page, to redirect you to the main page of the translated blog?
    By main page I refer to the one you get when you request the main URL of the site (eg: roadtolorien.kyopol.net)

    The correct behaviour would be that, by clicking on the language link you would be redirected to the "main page" of the translated blog. Instead of this, I am sent to the translation of the first post I created in the blog.

    The same behaviour happens when I go from the Spanish main page to English. I am sent to the first english post of the blog.

    Is there any way to set this correctly?

    http://wordpress.org/extend/plugins/multilingual-press/

  2. pedromauricio
    Member
    Posted 1 year ago #

    I'm having the same issue. Any news on how to solve this?

    [ Please do not bump, that's not permitted here. ]

  3. Robert Windisch
    Member
    Plugin Author

    Posted 1 year ago #

    Thank you for submitting this issue. It seems that the widget loads the last post in the loop. We will provide an update for this issue this week.

    Regards,
    Robert

  4. pedromauricio
    Member
    Posted 1 year ago #

    Hi Robert, any updates on this?

  5. Robert Windisch
    Member
    Plugin Author

    Posted 1 year ago #

    Hi,

    we have released an update which will fix that issue. Please update to the current version.

    regards,
    Robert

  6. pedro.prieto-martin
    Member
    Posted 1 year ago #

    Thank you very much. We will install and verify it is working.
    Kind regards,
    Pedro

  7. pedro.prieto-martin
    Member
    Posted 1 year ago #

    Dear Robert,
    I installed, after updating WP to 5.1.
    WP and Plugin seems to work, but this issue is still not resolved.
    When I am in the main page (with the list of blogs) and I hit on the little flag, instead of going to the main page (list of blogs) in the other language, I am still sent to an specific post. You can test on http://roadtolorien.kyopol.net

    Maybe some manual intervention is needed for existing intallations? Something to be changed in the db?
    Thanks for your support.

  8. pedro.prieto-martin
    Member
    Posted 1 year ago #

    Actually, the situation that I observe now is even worse.

    You mentioned in a previous post that the widget seemed to be loading the last post in the page.
    Indeed, it seems to be referring to the last post... but mixing both languages in generating a wrong URL.

    Example:
    Access the main page:
    http://roadtolorien.kyopol.net/

    The last post is:
    http://roadtolorien.kyopol.net/networking-upwards-networking-downwards/

    Whose equivalent in Spanish is:
    http://rumboalorien.kyopol.net/networking-parriba-networking-pabajo/

    But the URL generated for the flag on the main page is: http://rumboalorien.kyopol.net/networking-upwards-networking-downwards/

    Which mixes the Spanish Main URL with the English page name.
    As a result you are sent to a non-existing page.

  9. Robert Windisch
    Member
    Plugin Author

    Posted 1 year ago #

    Hi Pedro,

    we are currently working on a small update for the plugin. We have pushed a commit to gthub which could solve your problem. Please try the latest class-Mlp_Helpers.php from https://github.com/inpsyde/multilingual-press/blob/master/inc/class-Mlp_Helpers.php

    Please tell me if this solved your problem.

    regards,
    Robert

  10. pedro.prieto-martin
    Member
    Posted 1 year ago #

    Hi Robert,
    thanks for the quick update!
    I replaced the file you mention and now it is working. :-)

    Not sure if I should "mark this topic as resolved" now or wait till it is part of a release, so... I'll leave it as it is.
    Thanks!!
    Pedro

  11. Wigid Triyadi
    Member
    Posted 1 year ago #

    Hi Robert
    I have same problem with Pedro, and your advice solved it.
    please add the changes to plugin latest version

    cheers
    W

  12. toscho
    Member
    Plugin Author

    Posted 10 months ago #

    This has been fixed already.

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic