WordPress.org

Ready to get started?Download WordPress

Forums

MP3-jPlayer
Single track player problem in ajax-loaded pages (2 posts)

  1. adambundy
    Member
    Posted 2 years ago #

    I have some posts loading into a main template using jQ ajax, and I am using mp3j_put in my template (single.php) to load a single track for each page. The shortcode in the put function is just echoed out, but the player is not constructed/triggered. I have another player on the same page- could that be causing problems? Please advise how to make the player initiate correctly in these ajax-loaded pages. Here is the debug code, but the info is probably pertinent to the other player since the single-track player is not initiating:

    <!-- *** MP3-jPlayer ** version 1.7.3 Template: Singular Post Use tags: Yes Player count: 0 All active widgets: Array ( ) MP3's in Media Library: 1 Admin Settings: Array ( [initial_vol] => 50 [auto_play] => false [mp3_dir] => / [player_theme] => styleG [allow_remoteMp3] => true [playlist_AtoZ] => false [player_float] => none [player_onblog] => false [playlist_UseLibrary] => false [playlist_show] => false [remember_settings] => true [hide_mp3extension] => false [show_downloadmp3] => false [disable_template_tag] => false [db_plugin_version] => 1.7.3 [custom_stylesheet] => /wp-content/plugins/mp3-jplayer/css/player-silverALT.css [echo_debug] => false [add_track_numbering] => false [enable_popout] => true [playlist_repeat] => false [player_width] => 300 [popout_background] => [popout_background_image] => [colour_settings] => Array ( [screen_colour] => [screen_opacity] => [loadbar_colour] => [loadbar_opacity] => [posbar_colour] => [posbar_tint] => [posbar_opacity] => [screen_text_colour] => [playlist_colour] => [playlist_tint] => [playlist_opacity] => [list_text_colour] => [list_current_colour] => [list_hover_colour] => [listBGa_hover] => [listBGa_current] => [volume_grad] => [list_divider] => [indicator] => ) [use_fixed_css] => false [paddings_top] => 5px [paddings_bottom] => 40px [paddings_inner] => 35px [popout_max_height] => 600 [popout_width] => 400 [popout_button_title] => [max_list_height] => 100 [encode_files] => true [animate_sliders] => true ) -->

    Thanks!!

    http://wordpress.org/extend/plugins/mp3-jplayer/

  2. adambundy
    Member
    Posted 2 years ago #

    UPDATE: OK, the biggest issue here was my mistake (syntax error), but now I get the play button, but clicking it does nothing (no request or error or activity of any kind in net panel). There is a playlist player outside this ajax-loaded content that plays the same track URLs fine, so I know its not a bad file URL. Any idea what could cause this?

    Thanks!

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic