WordPress.org

Ready to get started?Download WordPress

Forums

MP3-jPlayer
Can't Get Widget to Work (3 posts)

  1. cyrus6
    Member
    Posted 3 years ago #

    Hi - I can't seem to get the widget to work in any mode unless I check "Show the player on the posts index page". See here:
    http://www.blueridgeoutdoors.com/BRO_DEV/

    Then I have to put a link to "mp3jplayer-text-sidebar.css" in my header.

    but then the player disappears from my interior page here:
    http://www.blueridgeoutdoors.com/BRO_DEV/special-sections/2010-festival-guide/test-player/

    Any insight? Thanks!

    http://wordpress.org/extend/plugins/mp3-jplayer/

  2. simon.ward
    Member
    Plugin Author

    Posted 3 years ago #

    Hi cyrus,

    BRO_DEV is a posts index page, so you'll need that option ticked if you want the player on it. You shouldn't be needing to force any scripts though (currently ticked)?

    I'm not sure on the test-player page, the widget is active but seems like it's in a sidebar that doesn't get used on your single post pages. What theme is this?

    Can you check see if other widgets will show in that sidebar on that page, like a standard recent posts widget for eg?

    Simon

  3. cyrus6
    Member
    Posted 3 years ago #

    Hey Simon,
    I figured out what I was doing wrong on the test-player page. I didn't have the "Give shortcodes priority over widget" box checked ( I was trying to have the player in the post - not a widget). I understand the home/index page issue now - I was confusing myself.

    However, the widget on the index page still wants to default to "mp3jplayer-text.css" unless I add the link into the header.

    Thanks again for your help, this is a really useful plugin!

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic