WordPress.org

Ready to get started?Download WordPress

Forums

mLanguage
Problem with menu of site and title of page (4 posts)

  1. yukiko-kawa
    Member
    Posted 3 years ago #

    Autor,
    I tried your wordpress plugin mlanguage, and I would like to report a bug:
    I installed your plug in and modified the theme page single.php, index.php and page.php with this code:

    before:

    title="Permanent Link to <?php the_title(); ?>"

    after:
    `title="Permanent Link to <?php echo strip_tags(get_the_title()); ?>"

    `
    then,I write the title of page in default language, and i white on the key :

    key: en
    value: the title of page

    but when I change language whit the widget , the "personal menĂ¹ widget" changes ALL the title with the English title!

    Could you please fix it?

    for eg. you can see my site:

    http://www.bibyportal.net/yukiko-kawa/chi-sono-2/

    default language : Italian
    second language : English

  2. sofiamotettkor
    Member
    Posted 3 years ago #

    Hi

    I have the same problem. Check out the "Meny" on the right, when you have chosen the english or italian version of the site:
    http://www.sofiamotettkor.se/

    All the links of the "Meny" (pages) get the name of the current page you're visiting, although they lead to different pages. In the default language (Swedish) this doesn't occur.

    Very greatful if you cold solve the problem, love the plugin otherwise.
    Thanks for the help!
    /Gerda

  3. Alexander Rauscha
    Member
    Plugin Author

    Posted 3 years ago #

    Hi,
    sry i haven't seen this post earlier.

    @yukiko-kawa

    This isn't really a bug, when you use strip_tags it will strip out all html tags which i need to hide the other languages. But if you want to use <?php the_title(); ?> in the title attribute, i would suggest you using this:

    <?php
    $title = the_title('','',false);
    preg_match('/<span>(.*)<\/span>/', $title, $m);
    echo strip_tags($m[0]);
    ?>

    @sofiamotettkor
    Thanks, i already know that page menu bug, but sadly i have no idea how to fix this in a proper way. I will keep up trying to fix it ;)

    -<o.o>-

  4. caiobeltrao
    Member
    Posted 3 years ago #

    Hi there,
    any solutions about the menu bug? I have the same problem here... all the menu items change to the same name.

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic

Tags