WordPress.org

Ready to get started?Download WordPress

Forums

Mingle Forum
Smilie icons & editing icons vertical instead of horizontal (10 posts)

  1. Sheila
    Member
    Posted 2 years ago #

    I've looked on the developers forum and found several people with this question but no answers. What’s happening is that when you go to post a new post the 2 “rows” that are the wysiwyg tools & smilies are displaying vertically instead of horizontally. Very odd. I’d actually like to disable the smilies entirely but we do need to keep the editing tools. I can't give you a link to the live site as it's still in development AND it will be in a protected area. But here's a screenshot:
    http://awesomescreenshot.com/0cbng5aec

    Please let me know if this is a bug, something I can change in the php or in the css.

    Thanks.

    http://wordpress.org/extend/plugins/mingle-forum/

  2. Sheila
    Member
    Posted 2 years ago #

    My niece was able to provide some CSS that corrects this. I will post it. I just don’t know why it was necessary!

    body.custom div#wpf-wrapper table.wpf-table br {
    display: none;
    }

  3. orrarah
    Member
    Posted 2 years ago #

    Hey

    I have the same problem. Can you tell me where exactly, did you put that code?

    Would really appreciate it!

  4. Sheila
    Member
    Posted 2 years ago #

    It goes in your CSS. You can put it in the mingle forum css, your general css or a custom css which is what I do so that it won't get overwritten during any updates.

  5. fuzzypiglet
    Member
    Posted 2 years ago #

    that code didnt work for me

  6. fuzzypiglet
    Member
    Posted 2 years ago #

    this code works though

    wpf-wrapper table.wpf-table br {
    display: none;
    }
  7. fuzzypiglet
    Member
    Posted 2 years ago #

    actually that code removes all the line breaks in the forums so its not good

  8. KaiMadsen
    Member
    Posted 2 years ago #

    WordPress sites tend to load a lot of css. The Firefox code inspector will help you find the culprit. The problem I found was a result of a css file setting the following:

    img { display: block; }

    The css you are looking for may not be exactly the same as the above but wherever you find it, make an entry in the same file similar to the following (including your wrapper-if-any code block designators):

    /* Allow Forum Editor Icons To Display Horizontal */
    .wrapper-if-any #wpf-wrapper img { display: inline; }

  9. rickgn
    Member
    Posted 1 year ago #

    I found another fix for this problem that doesn't involve CSS. It seems that if you remove the line break in between the <A> tags in wpf.class.php in both $buttons and $smileys it works. I'm not sure why this is a problem in some browsers. But if there is a space between the <a> <img> it tends to line break. Change these to <a><img>... </img></a><a>...

  10. rickgn
    Member
    Posted 1 year ago #

    I found the above issue in the code. I believe it was there so that the code looks pretty when editing. But the extra spaces and line breaks have an effect on the browser. The $button and $smileys needs to be all one code line with no spaces or breaks. This is a feature of PHP that works (sometimes) but can cause side effects like this.

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic