WordPress.org

Ready to get started?Download WordPress

Forums

Related Posts for WordPress
[Plugin: Microkid's Related Posts] error with php5.3 (4 posts)

  1. gilles66
    Member
    Posted 3 years ago #

    These are the error messages I have during ajax call to search related post
    I have php 5.3
    ==========================================================

    Deprecated: Assigning the return value of new by reference is deprecated in C:\__WORK\L_agence_originale\annedhercourt.com\www\wp-settings.php on line 204

    Deprecated: Assigning the return value of new by reference is deprecated in C:\__WORK\L_agence_originale\annedhercourt.com\www\wp-settings.php on line 219

    Deprecated: Assigning the return value of new by reference is deprecated in C:\__WORK\L_agence_originale\annedhercourt.com\www\wp-settings.php on line 226

    Deprecated: Assigning the return value of new by reference is deprecated in C:\__WORK\L_agence_originale\annedhercourt.com\www\wp-settings.php on line 233

    Deprecated: Assigning the return value of new by reference is deprecated in C:\__WORK\L_agence_originale\annedhercourt.com\www\wp-settings.php on line 258

    Deprecated: Function set_magic_quotes_runtime() is deprecated in C:\__WORK\L_agence_originale\annedhercourt.com\www\wp-settings.php on line 27

  2. microkid
    Member
    Plugin Author

    Posted 3 years ago #

    Is WP_DEBUG set to true in your wp-config.php?

  3. gilles66
    Member
    Posted 3 years ago #

    No, WP_DEBUG is set to false.

    To avoid the displaying of errors (deprecated) in the ajax return, I finally replaced this line
    require('../../../wp-config.php');

    by this block
    ob_start();
    require('../../../wp-config.php');
    ob_clean();

    in the file mrp-search.php

    And I remarked that there are a lot of deprecated errors in wp with php5.3.

    Gilles

  4. artflutter
    Member
    Posted 3 years ago #

    The warnings relate to the &= assignments in wp-settings.php being deprecated in php 5.3 so it's not an error in the plugin.

    I would've thought that setting WP_DEBUG to false would suppress the messages but for some reason that doesn't work for me.

    I just added error_reporting(0); to the top of mrp-search.php and that supresses the warnings.

    This is on WordPress 3.0.4, maybe they'll fix the code in future upgrades?

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic