WordPress.org

Ready to get started?Download WordPress

Forums

Meteor Slides
[resolved] Slide URL link dont work (25 posts)

  1. DUBBELDEEZ
    Member
    Posted 2 years ago #

    Hi when I insert a slide link URL in the box it doesn't link on the slider. Instead I get this link:

    "www.website.com/?slide=nameofslide"

    It just adds "?slide=nameofslide" behind my url website.
    Can u help me out, its very confusing.

    Thanks allot,
    Danny

    http://wordpress.org/extend/plugins/meteor-slides/

  2. Josh Leuze
    Member
    Plugin Author

    Posted 2 years ago #

    Hi Danny, most likely your theme is filtering post thumbnails, like the slide image and adding that post's permalink to the image, breaking the custom slide links.

    You should be able to find this filter in your functions.php file. If your site uses post thumbnails, you will have to add the permalink to them after you remove the filter.

  3. DUBBELDEEZ
    Member
    Posted 2 years ago #

    Wow thanks allot! That did it! Amazing.. Have a good one! Greetings from Amsterdam.

  4. Josh Leuze
    Member
    Plugin Author

    Posted 2 years ago #

    No problem Danny!

  5. niftythriftythings
    Member
    Posted 2 years ago #

    Hi!
    I'm having the same problem. My slides link to the name of the slide, instead of the link that I'm providing.
    Could you explain what I need to do with the functions.php a little more? I guess I'm not understanding it correctly..
    Thanks in advance,
    Vanessa

  6. Josh Leuze
    Member
    Plugin Author

    Posted 2 years ago #

    Hi Vanessa, what theme are you using, can you post a link to the site you're working on?

  7. niftythriftythings
    Member
    Posted 2 years ago #

    Thank you so much for your quick reply! I'm using my own theme..
    My functions.php looks like this:

    add_theme_support( 'post-thumbnails', array( 'post' ) );
    add_theme_support( 'post-thumbnails', array( 'page' ) );
    set_post_thumbnail_size( 600, 300 );
    add_filter( 'post_thumbnail_html', 'my_post_image_html', 10, 3 );
    function my_post_image_html( $html, $post_id, $post_image_id ) {
    $html = '<a href="' . get_permalink( $post_id ) . '" title="' . esc_attr( get_post_field( 'post_title', $post_id ) ) . '">' . $html . '</a>';
      return $html;
    }

    [Please post code snippets between backticks or use the code button.]

    I hope this helps to find a solution. :)
    Thank you so much for the support!

  8. Josh Leuze
    Member
    Plugin Author

    Posted 2 years ago #

    It is the filter that is breaking the links, try removing this:

    add_filter( 'post_thumbnail_html', 'my_post_image_html', 10, 3 );
    
    function my_post_image_html( $html, $post_id, $post_image_id ) {
    $html = '' . $html . '';
    return $html;
    }
  9. niftythriftythings
    Member
    Posted 2 years ago #

    I tried removing this part of the code.
    It does try to connect to the web address first now, but then redirects to the slide name again. I really don't know what I'm doing wrong..

  10. Josh Leuze
    Member
    Plugin Author

    Posted 2 years ago #

    Double check the rest of your theme to make sure you don't have any other similar filters. Do you have any other plugins installed that could be causing conflicts?

  11. niftythriftythings
    Member
    Posted 2 years ago #

    Ok, I narrowed it down to the "categories".
    I was trying to link to my categories (or labels) from the slides and that's when it redirects. If I link to a regular page in my blog, it works like a charm!
    I just can't figure out what exactly is causing it..
    Thank you so much for your help though!
    Greetings from Germany!

  12. Josh Leuze
    Member
    Plugin Author

    Posted 2 years ago #

    Could you post a link to your site. Maybe add a link to a regular page and another to a category so I can compare them?

  13. niftythriftythings
    Member
    Posted 2 years ago #

    Here's my page. It's not open to the public yet, so there's still a lot of things to do. ;)
    If you click on the slide that says "nifty thrifty sunday" it will link to my "about" page.
    The other slides are linked to a category and that's where they're redirecting..
    I really appreciate all the help!

  14. Josh Leuze
    Member
    Plugin Author

    Posted 2 years ago #

    No problem, it looks like this is just a coincidence. Links like this redirect to slides whether they are entered directly or clicked from the slideshow: http://www.niftythriftythings.com/categories/floral-friday/

    But it looks like the category links are actually entered like this: http://www.niftythriftythings.com/category/floral-friday/

    Is there supposed to be a page at the first link, or are they incorrect? It looks to me like WordPress is just redirecting to the slides because the slug happens to be the same.

  15. niftythriftythings
    Member
    Posted 2 years ago #

    Oh, wow! I don't think I would have ever figured it out without your help.
    I changed the href in the functions.php for the categories from "/categories/" to "/category/" and it's working great now!
    Thank you so much for all the help and for developing such a great plugin!
    Have a great rest of the week!

  16. Josh Leuze
    Member
    Plugin Author

    Posted 2 years ago #

    You're welcome, thanks for trying my plugin!

  17. 3easypayments
    Member
    Posted 2 years ago #

    I had the same problem with my theme and removing the function that auto-added links to thumbnails solved this for me too. This is a slick and easy to use plugin (I love the Slides menu to manage the slides -- even my clients can handle that) -- many thanks!

    PS: I use a theme generator tool so I'll have to keep removing this function from my generated functions.php file, which is not a big deal. But... if it would work if your plugin used !important when setting the href to take precedence on the slide images that would really be ideal in a future version. Then the nice theme auto-linking function could remain and wouldn't be in conflict.

    Thanks again.

  18. 3easypayments
    Member
    Posted 2 years ago #

    Meant to add one enhancement suggestion...

    Would be nice to have an option to set the alignment of the page icons to right instead of left (set .meteor-buttons {right: 0px;} instead of .meteor-buttons {left: 0px;}

    Thanks!

  19. Josh Leuze
    Member
    Plugin Author

    Posted 2 years ago #

    @3easypayments Thanks for the feedback, I'm glad you were able to get the links fixed.

    There's not much I can do on my end, I can't override markup for links in the same way that CSS can be. One option you would have if the the theme uses the same name for the filter every time, you could use remove_filter in a plugin to disable it.

  20. danstramer
    Member
    Posted 2 years ago #

    HI
    I need the post thumbnails filter working.
    How can it work together with meteor slides?
    Is there a fix for that?

    Thanks
    Dan

  21. @danstramer please start your own thread with your own details.

    http://wordpress.org/tags/meteor-slides?forum_id=10#postform

  22. miriamohrn
    Member
    Posted 1 year ago #

    Hello! Thank you for an excellent plug-in!! I'm also having troubles with the image URL. When I deleted the code snippet for the thumbnail filter the site crashed. My theme functions look like this:

    add_filter( 'post_thumbnail_html', 'grisaille_post_image_html', 10, 3 );
    function grisaille_post_image_html( $html, $post_id, $post_image_id ) {

    $html = '' . $html . '';

    return $html;
    }

    What part is safe to delete for the URL's to work? My theme is grisaille.

    Thanks so much!!

  23. Josh Leuze
    Member
    Plugin Author

    Posted 1 year ago #

    @miriamohrn You should be able to remove that without breaking anything, the blog thumbnails just won't have links. You could try just commenting out the filter to disable it without deleting anything:

    //add_filter( 'post_thumbnail_html', 'grisaille_post_image_html', 10, 3 );

    I would try adding a conditional to that function so that it only runs on the blog post post type:

    // THIS LINKS THE THUMBNAIL TO THE POST PERMALINK
    add_filter( 'post_thumbnail_html', 'grisaille_post_image_html', 10, 3 );
    function grisaille_post_image_html( $html, $post_id, $post_image_id ) {
    	if ( 'post' == get_post_type() ) {
    		$html = '<a href="' . get_permalink( $post_id ) . '" title="' . esc_attr( get_post_field( 'post_title', $post_id ) ) . '">' . $html . '</a>';
    		return $html;
    	}
    }
  24. miriamohrn
    Member
    Posted 1 year ago #

    Hi Josh! Thanks for your reply. I tried what you said but the same thing happened and I had to FTP the functions.php back up for the site to start running again.

    Any other suggestions? Maybe there is something wrong with my theme because it seems that as soon as I do the smallest thing in the functions file, it turns into the error 500.

    Thank you for your time!!

  25. Josh Leuze
    Member
    Plugin Author

    Posted 1 year ago #

    I tried commenting out the filter in a test site and it worked fine for me. Are you editing the file in a text editor or via WordPress? Try using a text editor like Notepad++ to help avoid mistakes.

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic