WordPress.org

Ready to get started?Download WordPress

Forums

Meteor Slides
[resolved] Remove slideshow when no javascript (5 posts)

  1. nick2price
    Member
    Posted 1 year ago #

    Hey. Slideshow works great but I want to handle the situation where the user has no javascript enabled. What I need to do in this situation is display an image instead. I have managed to do that with the following

    <?php if ( function_exists( 'meteor_slideshow' ) ) { meteor_slideshow(); } ?>
    <noscript><img src="<?php echo get_stylesheet_directory_uri(); ?>/images/reviews-slide.png"></img></noscript>

    The problem with the above is that the image is placed below where the slideshow would be, where I need it to replace the slideshow. So is there any function or anything to check for whether the slideshow is working, so I can remove it if it isnt?

    Cheers

    http://wordpress.org/extend/plugins/meteor-slides/

  2. Josh Leuze
    Member
    Plugin Author

    Posted 1 year ago #

    If JavaScript is disabled, the first slide should display as a static image, if it isn't there is probably a theme conflict and you could tweak the CSS to get it to display.

  3. johnnymauser
    Member
    Posted 1 year ago #

    I have the same problem. If JavaScript is disabled, there is a placholder with showing nothing but a white screen.

    Source code viewer says:

    Inline
    Element {visibility: hidden;}

    It's my first slider pic, that is hidden (and should not be).

    If I only knew, how to change my CSS to get it visible!!!!
    I worked a whole day to fixt it, all my (quite good) ideas did not help.

    Any angel around here that could help? :-) God may bless you !!!

    BTW: I love Meteor Slide and want to keep it desperately!

  4. Josh Leuze
    Member
    Plugin Author

    Posted 1 year ago #

    That image is supposed to be hidden, even with JavaScript disabled. This is very rare, almost no one uses a browser with out JavaScript enabled any more because you can't do hardly anything online without it these days.

    But you can add this to the stylesheet of your theme to display the first image of your slideshow as a static image when JavaScript isn't running:

    .meteor-slides .mslide-1 {
    	display: block;
    }
  5. johnnymauser
    Member
    Posted 1 year ago #

    Hey, thanks for your help!
    I am one of those who is using Noscript-Plugin for Firefox to avoid Javascript, so I appreciate every site looking fine without Javascript :-)
    I put your code to my stylesheet, my first image is showing now, but still not where it's supposed to be. There's still the placeholder and my first image starts displaying below of it.

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic