WordPress.org

Ready to get started?Download WordPress

Forums

Meteor Slides
meteor and WPML multi language software (6 posts)

  1. BenDov
    Member
    Posted 2 years ago #

    Hi there
    Meteor works great on my english page but does not show up on my hebrew page. What do I need to do to make it show up here. I have it just below the header and not in content.
    http://www.makorhatikvah.org/je

    Thanks

    http://wordpress.org/extend/plugins/meteor-slides/

  2. Josh Leuze
    Member
    Plugin Author

    Posted 2 years ago #

    Hi, how are you adding the slideshow? Are you using the template tag or the shortcode?

    Do you have it added to both the English and Hebrew content, same slideshow or a different one for each? If you are using multiple slideshows, check out this post and see if you might be having a similar problem: http://wordpress.org/support/topic/meteor-slides-and-wpml-multilingual-cms-problem?replies=8#post-1786111

  3. BenDov
    Member
    Posted 2 years ago #

    I am using thesis and have added it as a hook below the header. The code I used is below:

    <div style="background-image: url(http://www.makorhatikvah.org/thesis_images/content_top.jpg); height: 220px; width: 100%;"><?php if ( function_exists( 'meteor_slideshow' ) ) { meteor_slideshow(); } ?></div>

    Thanks
    PS Sorry I seem to have resubmitted the post so the same question will appear again. I don't see how to delete though.

  4. Josh Leuze
    Member
    Plugin Author

    Posted 2 years ago #

    The template tag should load the slideshow regardless of the language, I can see that the slideshow is loading on the Hebrew page, but no slides are loading.

    I think the issue is that the slides you have added are seen as "English" content, and there is no Hebrew equivalent for the slides so it is loading nothing.

    There should be a couple of options you could choose from to fix this. You could setup different slides for each language, if the slides have text and you need different slides for each. The other option would be to set it up to use the English content for each language. Otherwise, I think in WPML you have the option on the settings to disable translation on specific post types, like slides so that you can use them sitewide.

  5. BenDov
    Member
    Posted 2 years ago #

    Thanks so much for your help. I did have translate ticked on each slide. Once I took this off the slide came through.

    I guess I did not really understand what I was doing when I clicked on translate.

    Jeremy

  6. Josh Leuze
    Member
    Plugin Author

    Posted 2 years ago #

    No problem Jeremy, glad to hear you got it figured out!

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic