WordPress.org

Ready to get started?Download WordPress

Forums

Meteor Slides
[resolved] Images not showing up on my page (34 posts)

  1. nickkers
    Member
    Posted 2 years ago #

    Hello,
    I just downloaded Meteor slide because i want to have multiples slide shows. I have put the code into the php in the header

    <?php if( is_front_page() ) { ?>
          <section id="slider-wrapper" class="grid_24">
    
              <?php if ( function_exists( 'meteor_slideshow' ) ) { meteor_slideshow( "kelowna-projects", "" ); } ?>
          </section><!--#slider-->
    
         	<?php } ?>
         </div><!--.container-->

    however nothing at all(not even the slide show navigation) is showing up on my page
    http://rebobetonpumping.com/welcome/
    it should be right under the nav.

    any clue what I am doing wrong? I even tried to include a slide show as a widget on a side bar and nothing shows up either? when using firebug it says that the .meteor-clip visibility=hidden. Not sure if that is the problem or not.

    thanks :)

    http://wordpress.org/extend/plugins/meteor-slides/

  2. Josh Leuze
    Member
    Plugin Author

    Posted 2 years ago #

    Hi, there is a JavaScript conflict that is probably breaking the slideshow. In the custom.js file, the "$" shortcut is being used, this doesn't work with WordPress because jQuery is loaded in no-conflict mode, use the full "jQuery" version instead and it should work fine.

  3. nickkers
    Member
    Posted 2 years ago #

    Awesome thanks so much!

  4. Josh Leuze
    Member
    Plugin Author

    Posted 2 years ago #

    No problem!

  5. Jim
    Member
    Posted 1 year ago #

    Hi there and thanks for the plugin.

    I am also unable to display the Meteor Slides content.

    I don't see a custom.js file, however there is a slideshow.js.

    On line 11 reads, var $j = jQuery.noConflict();

    I suspect that this is what needs to be changed, but I'm not sure what it should be changed to.

    Please advise. Thanks again

  6. Josh Leuze
    Member
    Plugin Author

    Posted 1 year ago #

    It is supposed to be like that, the script uses a custom shortcut to avoid JavaScript conflicts. That custom.js is specific to the original poster's theme, the conflict you have is different, depending on your theme and plugins. If you want to post a link I can take a look.

  7. Jim
    Member
    Posted 1 year ago #

    The site is http://www.sportslifephotos.com/npr/

    Thanks again

  8. Jim
    Member
    Posted 1 year ago #

    Looks like the issue was caused by me including metadata="metadata" in the shortcode. I removed the metadata reference and now it works fine.

    Thank you for your time and the great plugin.

    Now I just need to figure out how to get the excerpt to display and I'll be golden.

  9. Josh Leuze
    Member
    Plugin Author

    Posted 1 year ago #

    That's good to hear, let me know if you have any problems adding excerpts to the slides.

  10. M11
    Member
    Posted 1 year ago #

    I've got the same issue. the slideshow isn't showing up.

    I used this code
    <?php if ( function_exists( 'meteor_slideshow' ) ) { meteor_slideshow(); } ?>

    on http://www.feestlust.nl/wordpress

    thx in advance :)

  11. Josh Leuze
    Member
    Plugin Author

    Posted 1 year ago #

    @M11 There's a JavaScript error:

    Uncaught TypeError: Property '$' of object [object Window] is not a function

    Your theme is disabling the default copy of jQuery that comes with WordPress and loading its own copy.

    This post should show you how to fix it, or you can try using the Restore jQuery plugin.

  12. M11
    Member
    Posted 1 year ago #

    ah the restore jquery plugin did the trick i guess :)
    now only some css-ing to place it right :)

    thx!

  13. Josh Leuze
    Member
    Plugin Author

    Posted 1 year ago #

    No problem!

  14. thano
    Member
    Posted 1 year ago #

    Great tool and looks beautiful on my website. However, images not showing up since I moved it to the cloud. I am not very good with css but I managed to run it on my local machine. here is my website: http://abslettings.bitnamiapp.com/wordpress/

    please help

  15. robert_cziczliper
    Member
    Posted 1 year ago #

    Hi Josh,

    Meteor Slides is great, i used in one of my client's website. With dummy pictures it worked perfectly but with real pictures it doesn't show up. Could you help me with that? The site url: http://tac.useless.web44.net/

    Thanks,
    Robert

  16. Josh Leuze
    Member
    Plugin Author

    Posted 1 year ago #

    Hi Robert, the slides in the slideshow are empty, no image tags at all. Are you sure the slide images are set on the slide posts? Are you seeing thumbnails of the slide images in the admin? I'd have to see the admin to know what's going, I can take a look if you want to send me a login.

  17. robert_cziczliper
    Member
    Posted 1 year ago #

    I sent you the login infos.

    Thanks,
    Robert

  18. Josh Leuze
    Member
    Plugin Author

    Posted 1 year ago #

    I took a look, the slide posts had images attached to them in the gallery, but they weren't actually set as the featured images. When they are added correctly, you will see a thumbnail of the slide in the slide post.

    Check out this video on adding slides if you're unsure how to add the images to the slides.

  19. robert_cziczliper
    Member
    Posted 1 year ago #

    Thanks for the help. It seems that i forgot how to add the slides.

  20. Josh Leuze
    Member
    Plugin Author

    Posted 1 year ago #

    No problem.

  21. Ica
    Member
    Posted 1 year ago #

    Hi JLeuze,

    I found your slideshow and am testing it on a website I'm making. But for some reason the images don't apear. The website I made is a child theme of the twentey ten theme. I do see the navigation once a scroll over. I have inserted this code in my header in the branding div.

    <div id="slideshow">

    <?php if ( function_exists( 'meteor_slideshow' ) ) { meteor_slideshow(); } ?>

    </div><!---/"slideshow"---->

    could you have a look and see what the problem is? I have correctly inserted the images in the back end selecting them as featured image. As well as created a slideshow to assign them to.

    This is the link to the website:
    http://www.mtgym.nl/New

  22. Josh Leuze
    Member
    Plugin Author

    Posted 1 year ago #

    @Ica There is a rule in the theme that is conflicting with the slideshow. Add this to your theme's stylesheet to fix it:

    .meteor-slides .mslide img,
    .meteor-slides .meteor-shim {
    	position: relative !important;
    }
  23. Ica
    Member
    Posted 1 year ago #

    Thanks Josh for the code! Great it works!! There is just one problem once a roll over the image it moves downwards. I changed the slideshow navigation options to none and then it was fixed. I guess I have to leave extra space for the navigation arrows in my style-sheet. Do you know how much?

    So happy the way the meteor slideshow works especial in the back-end keep the good work. Hope I can get to figure how to adjust the CSS of the meteor slides. I see you have documentation on this will look into that.

    all best

    Ica

  24. Josh Leuze
    Member
    Plugin Author

    Posted 1 year ago #

    You're welcome! There could be a style in your theme effecting the slideshow nav. They are a list, so the theme could be adding margin or padding to that list.

  25. Ica
    Member
    Posted 1 year ago #

    Thanks for the hint. I had seen in indeed the nav were lists ul but didn't make the link (I'm new in this). Thanks again will have a look to see if I can make it work.

    grtz
    ica

  26. nicolecdenton
    Member
    Posted 1 year ago #

    Hi there! I just added Meteor Slides to my site (http://weirdmusicfest.com/), and while it looks like the theme has added a place for the slides, none are actually showing up. Can you help?

  27. nicolecdenton
    Member
    Posted 1 year ago #

    Nevermind, got it working :)

  28. Josh Leuze
    Member
    Plugin Author

    Posted 1 year ago #

    Good to hear that you got it working Nicole, cool site!

  29. A.Tepina
    Member
    Posted 1 year ago #

    Hello. I am using Meteor Slides on my site http://seminar.outofthebox.si/, in the grey space bellow the header on the home page. However, they seem to not be displaying. They used to work, the change seemed to happen after some new slides were itroduced. I deleted those, but the problem seem to continue. I use a custom theme. Please, tell me if you need more information. Thank you in advance for the help.

  30. Josh Leuze
    Member
    Plugin Author

    Posted 1 year ago #

    @A.Tepina Hi, I checked and the slideshow isn't there in the code or anything, so it's not loading at all. How did you add the slideshow, did you use the slideshow template tag?

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic