WordPress.org

Ready to get started?Download WordPress

Forums

Meteor Slides
[resolved] I cannot place the Meteor slider on the correct place (14 posts)

  1. Pupy
    Member
    Posted 2 years ago #

    Hi, first of all I want to say that meteor slides is an excellent plugin, very well integrated in the wordpress functionality. Thanks for that.
    Now I will explain you my problem. The slider run very well but I cannot place it in the correct space. I am trying to replace my header image on my Home static page with the slider. I am using a theme of Weaver II Pro.
    After reading dozens of comments about this matter I opted by including the meteor code into the Per page options in a custom field and hide the standard image as suggested. The slider is there working fine, but in a wrong place. I use to have two Weaver Header Widgets on top of the header image and one header gadget over the image, but now after making these changes, those widgets and gadget appear on the bottom of the slider instead of in the top as they normally are.
    Could you give me some recommendations to solve this issue?
    Thanks in advance for your help
    Pupy

    http://wordpress.org/extend/plugins/meteor-slides/

  2. Josh Leuze
    Member
    Plugin Author

    Posted 2 years ago #

    Hi Pupy, can you post a link to the site you're working on?

  3. Pupy
    Member
    Posted 2 years ago #

  4. Pupy
    Member
    Posted 2 years ago #

    Just for your information, I am including the code "<?php if ( function_exists( 'meteor_slideshow' ) ) { meteor_slideshow(); }" in the last line of Stylesheet of my theme (Weaver II eCommerce 1.0). I donĀ“t know whether this is the correct place or not.

  5. MC
    Member
    Posted 2 years ago #

    I am approaching the same thing here. That code you refer to should go in the theme files, such as header.php

    However if you replace that in the header.php file, where it would generally add the featured header image ( if defined ), it would add the slideshow to every page on the site.

    I think that I am going to move the header logic into the page.php file, then overriding it for the home page using a custom page template. The plugin developer has a nice post on the subject here:
    http://www.jleuze.com/creating-your-own-page-templates/

    I am using a child theme of 2011 but the approach should be similar. I will let you know once I have it worked out. As well, I think this will allow me to drop slideshows in the header image on any page I need, unless I am going to use a basic header image instead.

    The plugin is well documented but this aspect of deployment is the only thing I didn't see covered on the site, so I am filling in the gaps with what I have learned so far about theming, so I may or may not be on the right track :)

  6. Pupy
    Member
    Posted 2 years ago #

    The fact is the slider runs perfectly on the assigned page but, theoretically, when I use the Per-page customs field "header" with the meteor value it should place the slider in the same place that the standard header. Unfortunately the widgets appear below the slider, so I think I am doing something wrong. It is my first time with WP and , needless to say, I am a complete newbie with php, codes ...

  7. Josh Leuze
    Member
    Plugin Author

    Posted 2 years ago #

    @Pupy I think the spot you are adding the slideshow template tag to is only for CSS, not PHP like the template tag. That only adds it to one spot in the header anyway so it won't be of use to you.

    There are a couple things you could try. You could use the slideshow shortcode in Weaver Admin > Advanced Settings > HTML Insertion > Site Header Insert Code. But that would be sitewide and it might still be above the widgets.

    Do you only need this on the homepage? To get it in the right spot, I would use the slideshow widget to add it to your header widgets, then you can move it where you want in relation to the other widgets. To get this widget loaded on just the homepage, try a plugin like Widget Logic.

  8. Josh Leuze
    Member
    Plugin Author

    Posted 2 years ago #

    @mcsolas I would use some conditional tags for this. Then you can keep it in your header and load it when you want to.

    You could use "is_front_page" or "is_home" to load it on just the homepage, or you could check if the page has a featured image and if it does load that instead of the slideshow. You could even get the page slug and check if there is a matching slideshow slug and load different slideshows on different pages dynamically.

  9. MC
    Member
    Posted 2 years ago #

    Thank you for pointing me in the right direction. I see this is a much better solution. I would have been reordering some wp basic functions into different files and I wasn't sure if that was the best idea. Maybe you should mention this on the docs. Thanks again for the help!

  10. Josh Leuze
    Member
    Plugin Author

    Posted 2 years ago #

    No problem!

  11. Pupy
    Member
    Posted 2 years ago #

    Thanks Josh for your support. I know it was not a Meteor issue but something related to WP. I will try to manage correctly the spots configuration. Yesterday I was unable to do it because I was fighting with migration issues to my root web. Best regards
    Pupy

  12. robert patrick
    Member
    Posted 2 years ago #

    ok guys , having a similar issue , i am working with a theme called tp sunrise , the site is

    http://www.d1023697.cp.blacknight.com/rockmountafcwp/

    i am trying to use the metor slide show plugin to insert a slideshow instead of a header image. i have done so already in this site using an animated gif but the file size is large and the quality poor.

    my html skills and css skills are good but php is a new to me allthough grasping it slowly.

    can you point me in the right direction.
    robert

  13. robert patrick
    Member
    Posted 2 years ago #

    that post went a bit funny the site i am working on is

    http://www.d1023697.cp.blacknight.com/rockmountafcwp/

  14. Josh Leuze
    Member
    Plugin Author

    Posted 2 years ago #

    Robert, I followed up with you in the thread you created.

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic