WordPress.org

Ready to get started?Download WordPress

Forums

Members
Invalid argument error on some sites after upgrade to 0.2 (1 post)

  1. pixelyzed
    Member
    Posted 3 years ago #

    Hi there!

    I've been using the Members plugin for several months on almost all of my sites without problems. I also upgraded many of those from 0.1.1 to 0.2 without issues except on a couple of sites where I get this error:

    Warning: Invalid argument supplied for foreach() in /path-to-site/wp-content/plugins/members/includes/capabilities.php on line 67

    When it happens, the error displays publicly (written to the page before any other content) but it does not appear in the admin where I get no warning or errors either during or after the upgrade.

    The strange thing is that, I get it on 1 single site on a largish multisite network where I have 52 separate sites and where Members is absolutely key for me to control what users have access to. Other sites seem to be unaffected so, since they all use the same theme and plugins, I doubt the error is caused by a plugin or theme conflict (the theme I use is Headway, I can give you a list of plugins if needed).

    The Member plugin settings are all the same on all sites except the main site which is different. The problem site is blog 2 which serves as my "template" site.

    So far I've seen the issue on one other site which is brand new and unfinished.

    Any idea what may be causing this issue?

    Thanks!

    http://wordpress.org/extend/plugins/members/

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic

Tags