WordPress.org

Ready to get started?Download WordPress

Forums

Media Library Assistant
[resolved] Problems with video (4 posts)

  1. Dmytro Baranetskyi
    Member
    Posted 1 year ago #

    Hello
    I apologize for my bad English.

    I created a category of video gallery (name video), but inserting the code [mla_gallery attachment_category = 'video'] into entry, the site did not appear. Videos uploaded to the gallery.
    What did I do wrong?
    Thank you.

    http://wordpress.org/extend/plugins/media-library-assistant/

  2. David Lingren
    Member
    Plugin Author

    Posted 1 year ago #

    Thanks for your question. The [mla_gallery] shortcode, like the WordPress [gallery] shortcode, defaults to showing only images ("post_mime_type=image"). You can try adding "post_mime_type=video" to your query. You might also want to add "size=icon" if the default gallery doesn't work the way you expect.

    I must confess that I have not done anything with video files in WordPress, and I'm not sure what will happen. I will do some experimenting and see what else I can do support video in [mla_gallery]. Thanks for helping me expand my horizons.

  3. David Lingren
    Member
    Plugin Author

    Posted 1 year ago #

    I've just done some testing after editing php.ini to increase "max_post_size" and "upload_max_filesize" so I could upload an MP4 file.

    If you add "post_mime_type=video" and "size=icon" to your query you will get a gallery with an appropriate icon for the file and the caption displayed beneath it. When you click on the icon you get an "attachment page" with the full description beneath a link to the video. Click on the link and the video will play in Quicktime or some other broswer video plugin. You can also add "link=file" to the gallery to bypass the attachment page.

    I think [mla_gallery] does the right thing for its part in the process. I'm going to mark this issue resolved.

    If you have any other questions or problems, let me know. Thanks for using the plugin!

  4. Dmytro Baranetskyi
    Member
    Posted 1 year ago #

    Thank you, David.
    I'll try to use your advice.

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic

Tags

No tags yet.