WordPress.org

Ready to get started?Download WordPress

Forums

MapPress Easy Google Maps
[resolved] Plugin could not be activated because it triggered a fatal error (7 posts)

  1. Thomas
    Member
    Posted 3 years ago #

    Fatal error: Cannot redeclare class Mappress in .../wp-content/plugins/mappress-google-maps-for-wordpress/mappress.php on line 19

  2. chrisvrichardson
    Member
    Plugin Author

    Posted 3 years ago #

    Hi,

    Please deactivate and reactivate the plugin. If you stil have the error, please contact me using the page below (I don't usually read the WP forums):

    Contact Page

  3. chrisvrichardson
    Member
    Plugin Author

    Posted 3 years ago #

    Found & fixed the error - thanks for reporting it. Should be OK in 2.0.1.

    2.0.1 also adds:
    - street view
    - enable/disable keyboard shortcuts

  4. Thomas
    Member
    Posted 3 years ago #

    ok, i deleted the extra '&', now it works just fine.

    however the map is displayed with large parts 'greyed out'.

    any thoughts? is it my theme?

    much thanks for the great work!

    thomas

    http://www.motivegallery.nl/?page_id=68

  5. chrisvrichardson
    Member
    Plugin Author

    Posted 3 years ago #

    Hi Thomas,

    I'm not sure what you meant about the '&' but the plugin seems to be working. I think the map is greyed out because of CSS settings in your theme conflict with Google maps.

    If a map is to be hidden it must be with "visibility: hidden' rather than 'display: none' on the map <div>. Otherwise Google has trouble determining the map size.

    I think your tab control (tabber.js?) is probably hiding the map. The comments say:

    /* When a tab is to be hidden, instead of setting display='none', we
    set the class of the div to classTabHide. In your screen
    stylesheet you should set classTabHide to display:none. In your
    print stylesheet you should set display:block to ensure that all
    the information is printed.
    */

    You could try setting your classTabHide to "visibility: hidden" instead, or try a different tab control.

  6. Mimmmi
    Member
    Posted 3 years ago #

    Hi there
    I am getting the same problem where i am trying to display the map in a tab, and only a small piece of the actual map is displayed in the top left corner.. the rest is greyed out. if i reload or refresh the page however, the entire map displays correctly. i do not want my users to have to refresh the page to see the map correclty.

    I did change my stylesheet for my tabs to visibility:hidden, as suggested by the above post, but this does not seem to have helped.

    Any help would be appreciated

  7. ekajatik
    Member
    Posted 3 years ago #

    I have exactly the same issue, have a map in a tab and the map is greyed out and a small section appearing top left only. Any solutions apart from the 'visibility:hidden' (which doesn;t work for me).

    Thanks

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic