WordPress.org

Ready to get started?Download WordPress

Forums

Plugin Manager by Dr. Dave! (11 posts)

  1. 7milesdown
    Member
    Posted 9 years ago #

    I successfully added the plugin manager. But it wont allow a one click install on my site. This is the error I recieve. any tips?

    Warning: exec(): Unable to fork [unzip c:\hosting\xxxx\member\xxxx\wordpress\wp-content\plugin_manager\tmp\tmp.zip -d c:\hosting\xxxx\member\xxxx\wordpress\wp-content\plugin_manager\tmp] in c:\hosting\xxxx\member\xxxx\wordpress\wp-plugin-mgr.php on line 449

  2. NuclearMoose
    Member
    Posted 9 years ago #

    I'd suggest going to wp-plugins.net and posting a support request there.

  3. 7milesdown
    Member
    Posted 9 years ago #

    I would have done that, unfortunately there is no where to ask questions. I dont want to put it on his blog, that would be rather rude. So I asked here in the support forum.

  4. callistawolf
    Member
    Posted 9 years ago #

    I'm having troubles too. I too looked at wp-plugins.net but saw nowhere to post my issue. I also tried posting on his blog at the plugin manager entry, but Spam Karma saw fit to eat my comment. Maybe someone here can help me out?

    I love this plugin, it has helped me so much. I haven't had a problem with it until today, in fact. I was going through and seeing what has been recently added. I did a one-click install of WP Theme Manager and that seemed to go okay. Then I was going to do a one click install of the new Theme Switcher plugin. That's when I got this error:

    Fatal error: Cannot redeclare rmdirr() (previously declared in /home/callis/public_html/inconceivable/wp-plugin-mgr.php:1314) in /home/callis/public_html/inconceivable/wp-content/plugins/wp-theme-mgr.php on line 188

    I have tried to deactivate and delete the plugin and reinstall it but I still get the error. Could someone please help me fix this?

  5. ColdForged
    Member
    Posted 9 years ago #

    Ah the joy of namespaces and function redefinitions in the plugin architecture. callistawolf, there's an incompatibility between the Plugin Manager and the Theme Manager plugin. As you've seen they both try to declare a function called "rmdirr". PHP hates it when people do that.

    You can fix this by opening either of the plugins -- I'd suggest the Theme Manager plugin -- in a text editor or the built-in theme editor if that's even available with the problem and changing all occurences of the word "rmdirr" with something like "wptm_rmdirr". I do mean all occurences... currently there are three that I see in the file. Once you do that you should be fine.

  6. ColdForged
    Member
    Posted 9 years ago #

    7milesdown,

    Do you have shell access on your site? If so, try running the "unzip" command directly from the shell. My guess would be your hosting provider doesn't have this program or an alias to it. You may need to ask them what the name of their unzip executable is.

  7. pezastic
    Member
    Posted 9 years ago #

    What's the deal with the plugin manager saying some plugins are compatible with WP 1.2 and/or WP 1.3? Can I use it with WP 1.5-gamma? I don't see any plugins listed that are compatible with the it. I, too, cannot find anywhere to post queries from the plugin manager site.

  8. ColdForged
    Member
    Posted 9 years ago #

    1.3 was rebadged to 1.5. Apparently the Plugin Manager simply hasn't been updated to reflect this fact.

  9. pgarrett
    Member
    Posted 9 years ago #

    I'm hoping someone can help me get the one-click plugin manager running for my site. I've tried version 1.4 and now the 1.6 beta with the exact same result (currently running WordPress 1.5-gamma 2005-02-08).

    When I browse to wp-plugin-mgr.php I get the 'Configuring Server' screen which has the message. I fill out the info and click 'permanent'. After a wait, I get the Plugin Manager with the following messages at the top:

    Changing permissions.
    Connected to FTP server...
    Logged on...
    Could not change 'wp-content/' permissions. Please change manually or check the ftp settings and try again.
    Could not change 'wp-content/plugins/' permissions. Please change manually or check the ftp settings and try again.
    Closed ftp connection...
    Connected to FTP server...
    Logged on...
    Could not change 'wp-content/plugin_manager/' permissions. Please change manually or check the ftp settings and try again.
    Could not change 'wp-content/plugin_manager/installed' permissions. Please change manually or check the ftp settings and try again.
    Could not change 'wp-content/plugin_manager/plugin_data' permissions. Please change manually or check the ftp settings and try again.
    Closed ftp connection...

    I also get these same messages after chmoding 0777 wp-content and wp-content/plugins.

    Something obviously doesn't like my setup but I can't figure it out. Any help would be appreciated.

  10. callistawolf
    Member
    Posted 9 years ago #

    ColdForged...

    Thanks.. :) I ended up just disabling and removing the ThemeManager plugin. I didn't need it as much as I wanted the Plugin Manager plugin. :) Though I imagine its very handy to those who dont' have access to the files on an FTP server. Thanks for your help!

  11. piginzen
    Member
    Posted 9 years ago #

    I have the same login problem that pgarrett is experiencing...

    Has anyone found a fix for this?

Topic Closed

This topic has been closed to new replies.

About this Topic