WordPress.org

Ready to get started?Download WordPress

Forums

WP User Avatar
[resolved] Plugin makes a site effectively unusable (9 posts)

  1. Quentin
    Member
    Posted 8 months ago #

    Load times of the site go from under a second to upwards of 10-15 seconds.
    Using plugin version 1.5.5
    Definitely this plugin, I've deactivated everything, and reactivated just this plugin. Not entirely sure what's causing the bottleneck, but it's a huge problem.

    http://wordpress.org/plugins/wp-user-avatar/

  2. Bangbay Siboliban
    Member
    Plugin Author

    Posted 8 months ago #

    Hi Quentin, could you tell me what theme you're using?

  3. holgerhubbs
    Member
    Posted 8 months ago #

    Me too... I am using the RESPONSIVE theme, and I had load times up to a minute.

  4. Bangbay Siboliban
    Member
    Plugin Author

    Posted 8 months ago #

    Try checking "Disable Gravatar and use only local avatars" in the WP User Avatar settings and see if that improves the load time. I acknowledge that a handful of users have complained about their sites' speed when using the plugin, but I haven't pinpointed what the exact problem is, and it's probable that it isn't the same problem for every user.

  5. Quentin
    Member
    Posted 8 months ago #

    I am using a custom built template.
    Unfortunately, it was too much of a problem, so I have had to use a different plugin for this functionality. I will see about setting up a sandbox site sometime and reinstalling the plugin to try and help you pinpoint the problem.

  6. holgerhubbs
    Member
    Posted 8 months ago #

    Like Quentin I also moved on to another plugin. I spent many hours with this problem until I realized that disabling your plugin speeded up things. And I don't even say that your plugin is defective.

    As a side note, when I installed the website on my local machine (Mamp on OS X 10.8) I had no delays.

    Thank you for providing this plugin, I used it for quite a while and enjoyed having it. Software can be delicate. I am sorry that I cannot be of further assistance I like to focus on other things.

    SIncerely,
    Holger

  7. holgerhubbs
    Member
    Posted 8 months ago #

    I stumbled upon another website of mine with your WP User Avatar.
    Turning on "Disable Gravatar and use only local avatars" did not cause any change.

  8. peteratomic
    Member
    Posted 8 months ago #

    Same issue for me. Page loads in the dashboard dropped to 5-10 minutes. (Using a responsive theme from Elegant Themes).

  9. Bangbay Siboliban
    Member
    Plugin Author

    Posted 8 months ago #

    I implemented a cache for Gravatar calls, which I think are the culprit for slowness. This is in version 1.5.7.

Reply

You must log in to post.

About this Plugin

About this Topic

Tags

No tags yet.