WordPress.org

Ready to get started?Download WordPress

Forums

Mailing List
fatal error when activating plugin (10 posts)

  1. brucedwilliams
    Member
    Posted 2 years ago #

    Plugin produces fatal error when attempting to activate. Nothing is logged in the log.txt file the author mentions in another forum thread.

    http://wordpress.org/extend/plugins/mailz/

  2. zingiri
    Member
    Plugin Author

    Posted 2 years ago #

    Is this a new installation or an upgrade? What version are you using?

  3. feelfree
    Member
    Posted 2 years ago #

    Error while installing the plugin on wp 3.2.1

  4. zingiri
    Member
    Plugin Author

    Posted 2 years ago #

    It would be helpful if you provide a bit more info about the error you're encountering ...

  5. Geoff Wass
    Member
    Posted 2 years ago #

    Zingiri,

    I can't say what the others encountered, but here is the error I get when installing on WordPress 3.2.1 on a WinXP machine:

    Plugin could not be activated because it triggered a fatal error.
    Could not create phpList database tables

    If there is anything else I can tell you that would help, let me know.

  6. zingiri
    Member
    Plugin Author

    Posted 2 years ago #

    Local installations are always the hardest to debug. Most likely curl missing, permission problems or really a database access problem.
    I suggest you try on a hosted Linux server.

  7. Geoff Wass
    Member
    Posted 2 years ago #

    Zingiri,

    Thank-you for the reply. It's a long story, but I have to develop locally for now and I will be uploading later (hopefully in the coming few weeks). I'll try again at that time when I can work on the host.

  8. uacstudios
    Member
    Posted 2 years ago #

    I found this error was because the server my website was hosted on didn't resolve the website's DNS name locally. Therefore, when cUrl tried to visit a URL to create the databases, it was failing to visit the local server. Append these two lines immediately after "function zing_mailz_activate() {" on line 115 of the mailz.php file in the root of the plugin:

    error_reporting(E_ALL);
    ini_set('display_errors', '1');

    If it is the same error, it will show you the URL which could not be resolved. You can visit this URL manually to create the tables in the database (hence the error when this is not done). Then retry activation and it should work.

    (Sorry if this doesn't make much sense, written in a hurry).

  9. uacstudios
    Member
    Posted 2 years ago #

    Also worth noting that this (cUrl to local address) seems to be the method that the plugin uses to display pages in the admin panel. Maybe a solution to the dev would be to have an option to use a proxy for the cUrl parts.

  10. Geoff Wass
    Member
    Posted 2 years ago #

    uacstudios,

    Thank-you for your message. You know more about this stuff than I do. I placed your snippet of code into mailz.php and got this when I tried to activate the plug-in on my local PC:

    Warning: HTTP Error:22/The requested URL returned error: 400 at http://localhost:28860/wp-content/plugins/mailz/lists/admin/index.php?plugin_status=all&paged=1&s=&page=initialise&firstintall=1&wpdb=DiNuovo2&wpf=wp_&wph=localhost&wpu=wordpressuser&wpp=MySQL123%21&wppageid=&wpsiteurl=http%3A%2F%2Flocalhost%3A28860 in C:\Documents and Settings\Work\My Documents\My Web Sites\DiNuovo2\wp-content\plugins\mailz\classes\http.class.php on line 186
     Could not create phpList database tables

    I have a feeling this is the same issue as you described. I am sure it will be useful to Zingiri.

    Thank-you again for sharing this.

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic

Tags