WordPress.org

Ready to get started?Download WordPress

Forums

[Plugin: MailChimp Widget] Unable to access wp_user_search.class.php (9 posts)

  1. itsfashionbaby
    Member
    Posted 3 years ago #

    I just installed MailChimp Widget, but when I activated it, I got the following messages:

    Warning: spl_autoload() [function.spl-autoload]: Unable to access wp_user_search.class.php in /var/www/itsfashionbaby.dk/public_html/wp-content/plugins/mailchimp-widget/mailchimp-widget.php on line 42

    Warning: spl_autoload() [function.spl-autoload]: Unable to access simplepie.class.php in /var/www/itsfashionbaby.dk/public_html/wp-content/plugins/mailchimp-widget/mailchimp-widget.php on line 42

    Warning: spl_autoload() [function.spl-autoload]: Unable to access simplepie.class.php in /var/www/itsfashionbaby.dk/public_html/wp-content/plugins/mailchimp-widget/mailchimp-widget.php on line 42

    Could someone please help me out?
    Thanks in advance :)

  2. jameslafferty
    Member
    Posted 3 years ago #

    Hi itsfashionably,

    Could you give me the versions of WordPress, PHP and Apache you're using? Thanks for trying out my plugin and I'm more than happy to help you try to figure out the issue.

    Cheers,

    James

  3. itsfashionbaby
    Member
    Posted 3 years ago #

    Hi James,

    Thank you so much for your very fast response :)
    WP is 3.05, PHP Version 5.3.3
    As for the Apache - is this correct? Apache API Version 19990320?

  4. jameslafferty
    Member
    Posted 3 years ago #

    Hi itsfashonbaby,

    Hmmm... Doesn't seem to be a version issue, then. Could you tell me which theme and which plugins you're using? Conflict must exist there... Also, please confirm that you're using the newest version of the MailChimp Widget.

    Cheers,

    James

  5. itsfashionbaby
    Member
    Posted 3 years ago #

    I've tried with several different themes - Thesis, Studiopress Lifestyle etc.
    My active plugins are: Akismet, All in one SEO, Feedburner Feedsmith, Google Analytics for WordPress, Google XML Sitemaps and Hyper Cache.

    And yes, I've upgraded to the latest version :)

    I'm getting this error:

    Warning: spl_autoload() [function.spl-autoload]: Unable to access wp_user_search.class.php in /var/www/itsfashionbaby.dk/public_html/wp-content/plugins/mailchimp-widget/mailchimp-widget.php on line 42

    Warning: spl_autoload() [function.spl-autoload]: Unable to access simplepie.class.php in /var/www/itsfashionbaby.dk/public_html/wp-content/plugins/mailchimp-widget/mailchimp-widget.php on line 42

    Warning: spl_autoload() [function.spl-autoload]: Unable to access simplepie.class.php in /var/www/itsfashionbaby.dk/public_html/wp-content/plugins/mailchimp-widget/mailchimp-widget.php on line 42

  6. jameslafferty
    Member
    Posted 3 years ago #

    I was not able to reproduce the error in my testing environment. Please get in touch with me off list, and I'll provide some more options for debugging, then we can report back here once we figure out what's going on. My email address is provided in the plugin documentation.

    Cheers,

    J.

  7. tackenco
    Member
    Posted 2 years ago #

    Hi James,

    I have the same problem here. Did you find a solution already? It would help me a lot!

    Thanks,
    Niels

  8. xnau
    Member
    Posted 2 years ago #

    I ran into this one today...what seems to be happening is the MailChimp plugin is registering a PHP autoload, and then when WordPress attempts to instantiate the User_Search class, it tries to use the plugin's autoload...which will fail because it's looking in the wrong place.

    I'm using an autoload in a plugin I'm writing, and what I've had to do is put in a check for the class file, if it finds it, it loads...if not, it ignores the request. Presumably, then, WordPress loads the class it needs with the correct autoloader.

  9. sporkme
    Member
    Posted 2 years ago #

    I'm curious if anyone else with this ongoing problem is running with open_basedir restrictions?

    It would be nice to have a quick workaround to be able to manually load what it's looking for (buffered_autoloader?).

Topic Closed

This topic has been closed to new replies.

About this Topic