WordPress.org

Ready to get started?Download WordPress

Forums

MailChimp Widget
[resolved] Fatal Error on Version 0.7 install (6 posts)

  1. aisaacs
    Member
    Posted 3 years ago #

    I had the previous version installed and it was working. When I updated, I got the following fatal error:

    Fatal error: Cannot redeclare class MCAPI in /home3/trustopa/public_html/wp-content/plugins/mailchimp-widget/lib/mcapi.class.php on line 3

    Help! :)

    Thanks,

    AI

    http://wordpress.org/extend/plugins/mailchimp-widget/

  2. jameslafferty
    Member
    Plugin Author

    Posted 3 years ago #

    Hi Al,

    It's complaining b/c the class MCAPI has already been declared. I'd thought that spl_autoload would take care of that, and not run if the class already existed. Are you using any other MailChimp plugins?

    Cheers,

    James

  3. aisaacs
    Member
    Posted 3 years ago #

    James,

    Thanks for the response! I am also using MailChimp Framework and MailChimp.

    Thanks,

    AI

  4. jameslafferty
    Member
    Plugin Author

    Posted 3 years ago #

    Hi Al,

    Just pushed a fix that should have it working correctly again. It broke b/c I checked in a patch I'd done for someone else. Sorry 'bout that, and let me know when it's working again (you'll be at version 0.7.1).

    J.

  5. aisaacs
    Member
    Posted 3 years ago #

    Sweet! Worked.

    Thanks,

    AI

  6. jameslafferty
    Member
    Plugin Author

    Posted 3 years ago #

    Whoot! Marking it resolved.

    J.

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic