WordPress.org

Ready to get started?Download WordPress

Forums

MailChimp Widget
Change private methods to protected (10 posts)

  1. ljungi
    Member
    Posted 2 years ago #

    Hi,

    just a suggestion: for a project of mine I have to extend your class to override the widget method for a completely different styling.

    Now I'm getting the error that I am not allowed to use your private methods.

    It'd be nice if you could change the methods to protected in further releases. Private doesn't make much sense in OOP anymore :)

    Thanks for the great plugin!

    http://wordpress.org/extend/plugins/mailchimp-widget/

  2. jameslafferty
    Member
    Plugin Author

    Posted 2 years ago #

    Hi ljungi,

    Thanks for trying it out, and for the comment. I think I agree with you, and I'll definitely plan on making that change with my next release (keeping as much as possible private was a habit I'd gotten into). Just need to find the time to work on my WordPress plugins... :)

    Cheers,

    J.

  3. Ian Dore
    Member
    Posted 2 years ago #

    James,

    weird one mate because I've seen it ruddy work!!

    No matter what I put into the plugin form, it will not submit and subscribe.

    any ideas old chum?

    cheers,

    ian

  4. jameslafferty
    Member
    Plugin Author

    Posted 2 years ago #

    Hi Ian,

    I think you've got a separate issue (what you're seeing is probably not related to protected vs. private methods in PHP)... Could you post a link to the WP installation where you're having difficulties?

    Cheers,

    James

  5. Ian Dore
    Member
    Posted 2 years ago #

    James hi mate, cheers for the reply.

    Here's a thing, if its got a redirect on will that make a difference?

    Its http://www.bathcitysound.com

    I can provide you with a user and pass if need be?

    cheers,

    ian

  6. jameslafferty
    Member
    Plugin Author

    Posted 2 years ago #

    Hi Ian,

    You're not using my widget plugin, but MailChimp's embedded form. Redirects are potentially an issue and I'd get in touch with MailChimp support to get help. I don't work for MailChimp btw... just wrote a plugin that integrates with their service. :)

    Cheers,

    J.

  7. Ian Dore
    Member
    Posted 2 years ago #

    Hi James,

    I have installed your widget ( Version 0.8.12 ) but you are probably seeing the redirect from the .com to the co.uk

    It is perhaps the redirect that is the problem. The widget is on the .com and the form on the .co.uk

    cheers,

    ian

  8. jameslafferty
    Member
    Plugin Author

    Posted 2 years ago #

    Hi Ian,

    I can't get to .com at all, so I'm fairly useless in terms of being able to help on this until I can see it.

    Cheers,

    James

  9. Ian Dore
    Member
    Posted 2 years ago #

    Hi James,

    I've just tried the same config on the .co.uk address and I'm afraid it still fails.

    cheers,

    ian

  10. jameslafferty
    Member
    Plugin Author

    Posted 2 years ago #

    I still can't get to an instance of my widget, so I can't help you. Could you give me a url to look at where it's failing for you? I'm totally happy to help you diagnose the issue, just can't do anything without being able to gather more information.

    Cheers,

    J.

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic