WordPress.org

Ready to get started?Download WordPress

Forums

MailChimp List Subscribe Form
[resolved] Translate error and confirmation message (16 posts)

  1. F1oren
    Member
    Posted 3 years ago #

    Hi

    I have WordPress 3.01 setup in french

    I have translate mailchimp fields in french on mailchimp website but I have always mailchimp message in the List Subscribe Form in English (eg : "you must fill in an email"

    How to translate this kind of message ?

    Regards

  2. F1oren
    Member
    Posted 3 years ago #

    ok I see that there is a french translation with .po file but how to activate it ?

    My wordpress administration is in french

  3. mc_jesse
    Member
    Posted 3 years ago #

    Here are the WordPress instructions for setting up your installation to be in a particular language:
    http://codex.wordpress.org/Installing_WordPress_in_Your_Language

    I can only assume that still works in WP3

  4. roelani
    Member
    Posted 3 years ago #

    @mc_jesse, I think the OP already has their WordPress language defined and configured properly, since the back end is in french on his/her install.

    @nohant, the problem you're looking stems from the plugin trying unsuccessfully to load a language (.mo) file from its /po/ directory. Open up mailchimp.php in your /plugins/mailchimp directory; around line 58, you'll see this bit of code:

    function mailchimpSF_plugin_init() {
    	// Internationalize the plugin
    	load_plugin_textdomain( 'mailchimp_i18n', MCSF_DIR.'po/');

    This is the bit that tells the plugin to load up the appropriate language file based on your WordPress installation language. It seems it can't find the right directory in some cases though. Just change it to:

    function mailchimpSF_plugin_init() {
    	// Internationalize the plugin
    	load_plugin_textdomain( 'mailchimp_i18n', false, dirname(plugin_basename( __FILE__ )) . '/po');

    This should make everything work again, and your Mailchimp plugin options in the back end will now also be in the correct language instead of the default english.

  5. morten.nielsen
    Member
    Posted 3 years ago #

    I have the same problem.
    I tried the suggested solution above, but it did not change anything. Unfortunately the text still says "You must fill in".
    Other texts are translated ok.
    The version I have is 1.2.1.

  6. mc_jesse
    Member
    Posted 3 years ago #

    @morten.nielsen that's quite a different problem. It sounds like the language you are using simply doesn't have that text properly translated.

    There are some basic translation instructions here if you want to take a look at your language file. I can, but all I'll be able to say is "yup, that's missing". If you can provide a proper translation for that string, we can include it.

  7. morten.nielsen
    Member
    Posted 3 years ago #

    I have translated the file as described in the link, also some text show up as expected.
    The language is da_DK (Danish, mailchimp_i18n-da_DK.po), but I did not finish all yet, so haven't mailed it.
    I'm quite sure I also translated the "You must fill in" string.

    #: mailchimp_includes.php:27
    #: mailchimp_includes.php:62
    msgid "You must fill in"
    msgstr "Du skal udfylde"

  8. mc_jesse
    Member
    Posted 3 years ago #

    I see what happened - when 1.2 was rewritten, the string being translated was changed from "You must fill in" to "You must fill in %s.", but the language files were not updated. I just updated them all and committed them to v1.2.1 of the plugin. They should be available in 15-30 minutes, so just reinstall the plugin then. Do be sure to backup the work you've done on that one, though!

  9. morten.nielsen
    Member
    Posted 3 years ago #

    Yep, now it's working - thanks a lot for your help!

  10. Destillator
    Member
    Posted 3 years ago #

    I have similar problems with the Mailchimp plugin 1.2.1 and a dutch WP installation. The widget text would not update, but after I changed the settings in Mailchimp the fieldname was updated in my language. The error-texts, such as "That email address is invalid" stay in the english language and do not translate. My WP installation is in Dutch, and the above solution from roelani doesn't help either. All texts in the language file mailchimp_i18n-nl_NL.mo seem to be in order. Does anyone have a suggestion for me where to look next?

  11. Destillator
    Member
    Posted 3 years ago #

    My language problem is solved by Pantaluna thanks to this post: http://wordpress.org/support/topic/plugin-mailchimp-list-subscribe-form-wrong-language-in-the-signup-widget

    It seems that the mailchimp plugin isn't that WP3 friendly if you switch it to another language, hopefully this will be fixed in a future release.

  12. mc_jesse
    Member
    Posted 3 years ago #

    @Destillator as I mentioned in my follow-up comments on that post, it's not exactly clear what the intended setup is, so "the mailchimp plugin isn't that WP3 friendly if you switch it to another language" is not accurate and "hopefully this will be fixed in a future release" is not realistic without an official statement from the WP folks.

  13. Destillator
    Member
    Posted 3 years ago #

    Thanks for the clarification!

  14. digitoff
    Member
    Posted 2 years ago #

    I did install wp mailchimp plugin it work good for one site without embed any code only setting the plugin,
    For others website did not work , I embed a code to have the mail form on the site,
    But a problem with the subscribe button on the mail form ,after you fill the information and you push the button nothing appear in the same time when i look at my in-box I find the subscription confirmation request.

    But as a visitor to the web will not notice that .

    mailchimp support said ( It looks like, though, either the javascript is disabled for the plugin, or it may be conflicting with other javascript on the page.)

    Please if any one can solve this problem, this is the web http://www.getdigitaloffers.com

  15. mc_nate
    Member
    Posted 2 years ago #

    Generally, when we see the form submit, but not produce any sort of inline validation, it's due to some sort of Javascript or jquery conflict.

    Essentially, there are a couple of fixes that can be put into place to produce this "success" or "error" message. The quickest fix would be to use one of the many MailChimp plugins for WordPress. We'd definitely suggest starting with the official plugin (http://wordpress.org/extend/plugins/mailchimp/), but there are a few other great ones out there. Whatever suits you the best!

    If you want to avoid installing a plugin, it is possible to produce a success or error page by disabling javascript from the embedded form. What you'll want to do is generate a new embed form code from your MailChimp list and check the "disable all javascript" box. Here's a screenshot of where to click:

    http://screencast.com/t/Ln1HF2GV

    Disabling javascript will create a popup page to display that specific success or error message. The popup can be edited, here:

    How do I customize each part of the confirmation process?: http://eepurl.com/gOGY

    Let us know if we can help with anything else!

    Cheers

  16. digitoff
    Member
    Posted 2 years ago #

    mc_nate
    Thanks for your help it work as it should be .Cheers

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic

Tags