WordPress.org

Ready to get started?Download WordPress

Forums

MailChimp List Subscribe Form
Mailchimp widget subscribe box needs aligning (42 posts)

  1. Nickie_VZ
    Member
    Posted 1 year ago #

    Sorry phone playing up. See example above on my previous post to give you an idea. The CSS references can be found on MailChimp for each field. Hope that helps with that part of your query. Nickie

  2. plonde
    Member
    Posted 1 year ago #

    @Nickie_VZ
    thanks for this incredibly thorough reply. Unfortunately, I'm not as savvy at this as you!

    You said
    If you look in the form design area, the last section is share it

    Where do I find the form design area...?
    do you mean where it gives options for colors, etc?
    if so, i'm not seeing anything for share it.

    or under the main left "nav" for settings?
    general, writing, reading, discussion, media, privacy, etc.
    sharing is the last one there.

    but then i have options to add sharing buttons like FB, twitter, stumbleupon, etc.

    thanks for your time and help to clarify.

  3. Nickie_VZ
    Member
    Posted 1 year ago #

    Hi Plonde.

    Sorry, to clarify, the share it section I'm referring to is actually in Mailchimp (not in WordPress) when you sign into your account there. Go into the list for the form you want to embed on your WordPress page and then go into the form where you normally brand up your forms. The share it section where you can generate the code is there.

    If you need anymore help, just let me know.

    Nickie

  4. plonde
    Member
    Posted 1 year ago #

    @Nickie - it worked! thanks!

  5. Nickie_VZ
    Member
    Posted 1 year ago #

    @plonde brilliant, glad to see it helped :)

  6. mc_nate
    Member
    Posted 1 year ago #

    Just wanted to check and make sure we're all good here?

    @Plonde -- you mentioned that the form is all centered, it looks like that's pulling from some other CSS in the site:

    box.ads .content {
    text-align: center;
    }

    However, if you set the text to align left in the form, that should override that area:

    #mc_signup_form {
    text-align: left;
    }

    As far as having all of the "Preferred Format" options on one line, it's probably easier just to skip that field, entirely. Most email clients in 2012 shouldn't have any problem receiving full HTML email (this includes mobile devices, as well). You could either remove that option from the list, or hide it in the CSS. For more info on that, check out this post:

    http://wordpress.org/support/topic/plugin-mailchimp-list-subscribe-form-remove-preferred-format?replies=2

    And let us know if we can help with anything else! :)

    Cheers

  7. recksteve
    Member
    Posted 1 year ago #

    I'm having the same problem with my entry boxes not being blocked to the left. I added this code to my style.css

    #mc_signup_form .mc_input {
    display: block;}

    I'm not as tech savvy as the other posters on this list so I don't know if I put it in the right place. It is currently right before the footer area.

    What do I need to do to have the email, first and last names appear consistently?

    The site is http://www.MyGolfBag.co.nz

    Thanks,

    Steve

  8. mc_nate
    Member
    Posted 1 year ago #

    Hey there!

    I had a look at the site, but it appears as though all is well! :)

    Here's how things rendered for me:

    Screenshot -- http://cl.ly/image/3B0R0E0E3T3G

    Cheers

  9. recksteve
    Member
    Posted 1 year ago #

    I see that now. I refreshed a number of times after putting in the code and it hadn't changed. Is there a way of getting the form to display other field names?

    Thank you for your help.

  10. mc_nate
    Member
    Posted 1 year ago #

    Ah. That sounds like a caching issue of some sorts.

    Anyway, with "other field names", what do you mean, exactly? The plugin should be able to pull in any field that's in your MailChimp list. You'll just want to go to "Settings" -> "MailChimp Setup", and at the bottom of the MailChimp options, you should see a list of checkboxes that correspond to fields in your list.

    Screenshot -- http://cl.ly/image/010131403k0f

    Check the ones you'd like to include and then click the "Update Subscribe Form Settings" button.

    If you'd like to add additional fields, that will need to be done on the MailChimp side of things:

    How do I add more fields to my list?: http://eepurl.com/gOHW

    After that, you'll go back to WordPress, and from the "MailChimp Setup" screen, click the "update list" option.

    Screenshot -- http://cl.ly/image/3V2Y0P2V3y25

    Cheers

  11. recksteve
    Member
    Posted 1 year ago #

    Thanks for the help. I have added a field in MailChimp, but it doesn't appear on the WordPress side. It's been 12 hours, but I will continue to look for it as a caching problem like before. Also, is it possible to get rid of the HTML, Text or mobile radio box.

    Thanks for dealing with my newbie questions.

    Steve

  12. mc_nate
    Member
    Posted 1 year ago #

    Hey again, recksteve!

    If you're not seeing the fields in your list, you might need to use the "Update List" button from the MailChimp Settings page in WordPress.

    As far as getting rid of the "Preferred Format" options, there's actually two ways to do that, depending on how involved you want to get. Check out this thread for the details:

    http://wordpress.org/support/topic/plugin-mailchimp-list-subscribe-form-disable-preferred-fomat-options?replies=6

    And there's no such thing as a "newbie question". I'm happy to help in any way that I can! :)

    Cheers

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic

Tags