WordPress.org

Ready to get started?Download WordPress

Forums

[Plugin: Magic Gallery] images open in a blank page instead of lightbox (12 posts)

  1. mmtomm
    Member
    Posted 3 years ago #

    Hi from Vienna!

    I'm using Magic Gallery Version 2.0 on WP 3.1 (may this is causing the troubles).
    It works fine displaying the thumbs, but when I click an image it opens in a blank page, like leaving my theme or like target="_parent"
    http://GuterStoff.com/aktuell/2011/03/884/test-magic-gallery

    any idea about this issue?

    Thanks and greetings from vienna
    Tom

    PS: late but just noticed, that my Featured Content Gallery slider on the startpage of my site is not working anymore since magic gallery is installed, so I disabled magic gallery for now.
    Any idea how to solve this interference?

  2. gerbenvandijk
    Member
    Posted 3 years ago #

    Hi there mmtomm!

    I've checked the source on your website, it's conflicting with some other scripts you are using.. You should disable one of them i guess.

    Regards,

    Gerben van Dijk

  3. mmtomm
    Member
    Posted 3 years ago #

    Hi Gerben,

    yes I'm affraid so, but thank you for looking!
    You think it is a lot of complicated coding to use Pikachoose at the startpage instead of Featured Content Gallery but getting the images from the userdefined field of the posts
    OK, when I write this it seems tooo complicated already :)

    But: is it possible to use on one page lightbox and on another pikachoose?

    Thank you very much!
    Tom

  4. gerbenvandijk
    Member
    Posted 3 years ago #

    Hi mmtomm,

    You could open up gallery.php and remove the lines 91-136.
    This will stop the loading of scripts of my gallery.

    Then in your header.php (in the theme), add something like this:

    <?php if (is_home()) {
    
    echo 'links to scripts and styles of pikachoose here';
    
    }
    ?>

    More about the WordPress function is_home can be found here: http://codex.wordpress.org/Function_Reference/is_home

  5. gerbenvandijk
    Member
    Posted 3 years ago #

    Hi there,

    You could try this, I'm not sure if it will work but you can try it out:

    <?php if (is_home()) {
    
        wp_register_style( 'pikachoosestyle', ''.WP_PLUGIN_URL.'/magic-gallery/css/styles.css', null, null);
        wp_enqueue_style( 'pikachoosestyle');
    
        wp_register_style( 'jquerylightboxstyle', ''.WP_PLUGIN_URL.'/magic-gallery/css/jquery.lightbox-0.5.css', null, null);
        wp_enqueue_style( 'jquerylightboxstyle');
    
     	wp_deregister_script('jquery');
        wp_register_script( 'jquery', ''.WP_PLUGIN_URL.'/magic-gallery/js/jquery.js', null, null);
    	wp_enqueue_script('jquery');
    
        wp_register_script( 'pikachoose', ''.WP_PLUGIN_URL.'/magic-gallery/js/jquery.pikachoose.full.js', null, null);
    	wp_enqueue_script('pikachoose');
    
        wp_register_script( 'jcarousel', ''.WP_PLUGIN_URL.'/magic-gallery/js/jquery.jcarousel.min.js', null, null);
     	wp_enqueue_script('jcarousel');
    
    	wp_register_script( 'jquerylightbox', ''.WP_PLUGIN_URL.'/magic-gallery/js/jquery.lightbox-0.5.js', null, null);
    	wp_enqueue_script('jquerylightbox');	
    
    }
    
    ?>

    Good luck, I hope I was of assistance!

  6. mmtomm
    Member
    Posted 3 years ago #

    :) good luck is good :)

    question: it is not possible to add such options in the post itself, isn't it?

    like instead of saying:
    [gallery id="1"]
    to say:
    [gallery id="1" album_type="pikachoose"]

    To summarize your above tipps (because I'm a non coder)

    1. removing the lines 91-136 in gallery.php
    2. put one of the options of your last post in the appropriate php-file i.e. `<?php if (is_home()) {

    wp_register_style( 'pikachoosestyle', ''.WP_PLUGIN_URL.'/magic-gallery/css/styles.css', null, null);
    wp_enqueue_style( 'pikachoosestyle');
    wp_register_script( 'pikachoose', ''.WP_PLUGIN_URL.'/magic-gallery/js/jquery.pikachoose.full.js', null, null);
    wp_enqueue_script('pikachoose');

    }
    ?>`
    sorry to bother you
    Tom

  7. gerbenvandijk
    Member
    Posted 3 years ago #

    At the moment it isn't supported like that indeed, and I don't think I will make support for that, sorry :)

    I would suggest to you just to copy the code I sent you. This makes sure the widget will work too.

  8. gerbenvandijk
    Member
    Posted 3 years ago #

    Hi there mmtomm, did you solve the problem?

  9. mmtomm
    Member
    Posted 3 years ago #

    Hi,

    I solved it by disabling featured content gallery and adding dynamic content gallery with jquery.
    Now they work both

    Thnks
    Tom

  10. gerbenvandijk
    Member
    Posted 3 years ago #

    Ah, yeah i'm figuring it will conflict sometimes with other plugins also trying to use jquery or using a different version of jquery.. Nothing I can do about that I'm afraid :)

    Glad to hear you solved it!

    Regards,

    Gerben van Dijk

  11. mumford
    Member
    Posted 2 years ago #

    Hi

    I really hope you can help, I am having trouble getting the lightbox to work when I have Pikachoose selected.

    The lightbox does not open and when I click on the larger image it just jumps to the top of the page?

    Any ideas?

    Many Thanks

  12. gerbenvandijk
    Member
    Posted 2 years ago #

    Hi mumford. The lightbox is not supported inside Pikachoose. You can choose either pikachoose, or a lightbox. In the new 3.0 version there will be an option to do this, check out http://www.magicgalleryplugin.com for more info.

Topic Closed

This topic has been closed to new replies.

About this Topic