WordPress.org

Ready to get started?Download WordPress

Forums

Magic Gallery
Add album under Manage Albums silently fails (6 posts)

  1. toddsc
    Member
    Posted 3 years ago #

    I'm thinking there's a permission problem, though I have chmod'd uploads and cache to 777...but when I try to add a gallery with any name, it silently fails.

    I try adding an image (but there's no albums to upload to) and do get error: "There was an error uploading the file, please try again!"

    One interesting thing...on the manage albums page, there are two bars that show up one on top of the other...I assume this is for top and bottom if there are albums present.
    ID Title Description Shortcode Delete
    ID Title Description Shortcode Delete

    Is there any way to enable debug output to try to find what is failing?

    http://wordpress.org/extend/plugins/magic-gallery/

  2. gerbenvandijk
    Member
    Plugin Author

    Posted 3 years ago #

    Did you chmodded the folder recursively (all the contents too)?

    I'll take a look into debugging code for you.

    Regards,

    Gerben van Dijk

  3. toddsc
    Member
    Posted 3 years ago #

    after giving up for a while, I went back and made sure the folders got recursively chmodded.

    Then I turned on WP debugging

    Now, I get an error that the database [DB_NAME].wp_gallery doesn't exist.

    Is that supposed to get created by WordPress? Is it possible the database is DB_NAME.wordpress_gallery or some other name? I'll see if I can log into my host and find any gallery databases.

  4. toddsc
    Member
    Posted 3 years ago #

    Ok, I checked, and I only have one database, none ending with wp_gallery.
    my config.php matches the DB_NAME from the debug message.
    I searched the plugin code and couldn't find any reference to wp_gallery so I'm guessing it's coming from something else. Any ideas?

  5. toddsc
    Member
    Posted 3 years ago #

    to clarify, in my config.php, the DB_NAME without the .wp_gallery exists, which matches the database I found on my server.

  6. gerbenvandijk
    Member
    Plugin Author

    Posted 3 years ago #

    Hi there toddsc,

    There shouldnt be a seperate database for the gallery, only a table in the database that wordpress uses, so that sounds normal. The table should be called (wp_gallery).. What kind of database are you using?
    Also, what version of the plugin are you using?

    Regards,

    Gerben van Dijk

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic