WordPress.org

Ready to get started?Download WordPress

Forums

Magic Fields
Doesn't work with 3.3+ (8 posts)

  1. Joe Hoyle
    Human Made
    Posted 2 years ago #

    The TinyMCE editor stuff changed a bit in 3.3 which broke compat with magic fields.

    I have had to make several patches, let me know if you want me to submit them somewhere.

    http://wordpress.org/extend/plugins/magic-fields/

  2. Michael
    Member
    Posted 2 years ago #

    Not sure where they're officially supposed to be posted, but if you wouldn't mind posting them here I (and I'm sure lots of other people) would greatly appreciate it.

  3. Joe Hoyle
    Human Made
    Posted 2 years ago #

    I opened a pull request here: https://github.com/hunk/Magic-Fields/pull/157

    clone from git@github.com:humanmade/Magic-Fields.git to use a version compatibile with 3.3

  4. Michael
    Member
    Posted 2 years ago #

    Thats great Joe, thanks. However I'm also having a problem where TinyMCE isn't loading on multiline fields, I guess you're not having that problem?

  5. Joe Hoyle
    Human Made
    Posted 2 years ago #

    Hmm, I don't remember having that issue no, so unless I made a fixed without thinking about it, I don't think so.

  6. Joe Hoyle
    Human Made
    Posted 2 years ago #

    Ahh, try switching to HTML editor in the main content area, then reload the page. For some reason, if you don't have the TinyMCE Visual view set on teh main content, other TinyMCEs don't work.

  7. ccgjosh
    Member
    Posted 2 years ago #

    I was having the same problem, looks like the new version of WP has removed some files in tinymce. Here's how I fixed:

    - Download the latest tinymce at http://www.tinymce.com/download/download.php

    - Copy the 'simple' folder: tinymce/jscripts/tiny_mce/themes/simple

    - Upload the simple folder to /wp-includes/js/tinymce/themes

    Looks a little different but it works.

  8. eastbank
    Member
    Posted 2 years ago #

    I'm on WP 3.3.1 and had this problem when I used Magic Fields on a custom post type. The problem was that I did not have the 'editor' turned on for the post type, so the TinyMCE wasn't showing up on the multiline text fields.

    The solution was to turn on the editor, when i did that the problem went away.

    I did not want the editor to be seen or used by the client though, so to fix that, I put this in the 'help text' area of the first magic field:
    <style type=text/css>#postdivrich {display:none;}</style>

    I was aware of this problem, and the fix for it because I use Custom Field Template quite often and it has the same issue.

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic