WordPress.org

Ready to get started?Download WordPress

Forums

Magento WordPress Integration
[resolved] Invalid URL (5 posts)

  1. dweb2012
    Member
    Posted 2 years ago #

    Hello,
    I try to setup the mage.php path but i receive this message : Invalid URL
    Wordpress and Magento are installed on the same server but :
    Wordpress is installed on a sub-domain : sub-domain.domain.com
    Magento is installed on http://www.domain.com
    Thank you

    http://wordpress.org/extend/plugins/magento-wordpress-integration/

  2. jamesckemp
    Member
    Plugin Author

    Posted 2 years ago #

    Hi dweb2012,

    Please make sure you write Mage.php, the uppercase M is very important!

  3. chrisemersonnc
    Member
    Posted 1 year ago #

    Same prob as dweb2012 here ... but I am using uppercase M. I'm using the following for my path string: /magento/app/Mage.php .. but am getting the "Invalid URL" message. Please help!

    Also, when I try entering a file-system path the entire Mage/WP options window ends up blank! Example: [C:\\inetput\\mysite\\magento\\app\\Mage.php]
    At this point I have to go into the WP database and clear the mage path string just to get the Mage/WP options window to show again.

  4. jamesckemp
    Member
    Plugin Author

    Posted 1 year ago #

    A couple of things going wrong here: The path is incorrect - it needs to be from the document root, this should be partly pre-filled when you first install the plugin. If you can't find that any more, create a file called test.php and place it on your server. Add:

    <?php echo $_SERVER['DOCUMENT_ROOT']; ?>

    Load the file and it will echo the path to your document root. Then add the path to mage on there. SHould end up similar to this:

    /example.com/www/public/app/Mage.php

    Second issue: Mage is loading, however it seems you may not have edited the functions.php in Magento, this is a required step: http://magentowp.com/documentation/installation/

  5. jamesckemp
    Member
    Plugin Author

    Posted 1 year ago #

    I'm assuming this is fixed now, marking as resolved!

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic

Tags

No tags yet.