WordPress.org

Ready to get started?Download WordPress

Forums

liveTV Bundle
[resolved] Problem to turn Online the thumbnail (33 posts)

  1. Gabriel Cunha
    Member
    Posted 1 year ago #

    First of all, sorry my horrible english, but I will try to show my problem.

    I think do something wrong, but I check the config, thats all ok.
    thats is my page: http://vti-gaming.com.br/wordpress/?page_id=129
    The problem is: All time, the thumbnail show offline, but the stream is online. I don't understand this.

    Thanks for your atention.

    http://wordpress.org/extend/plugins/livetv-bundle/

  2. sash2012
    Member
    Posted 1 year ago #

    First of all:

    Why is your channelname "Admin"?

    You need to add a new user and add the ID (for own3d) or the name (twitch/justin) on the bottom of the user.

    You added this at the moment: http://twitch.tv/admin

    And remember: Do not use uppercase letters for the usernames

    Example: uSeR - Wrong
    user - correct

    Best regards,
    sash

  3. Gabriel Cunha
    Member
    Posted 1 year ago #

    Well, I use on profile the name on twitch, but I will make other user to try.

  4. Gabriel Cunha
    Member
    Posted 1 year ago #

    Just check if i do the correct.

  5. Gabriel Cunha
    Member
    Posted 1 year ago #

    I do what you say, but staying offline when the streaming is on.

  6. KwarK
    Member
    Plugin Author

    Posted 1 year ago #

    Maybe you have a cache system like wp3-total-cache, wp-super-cache and then your page live stream isn't (re)generated ? If you use a dedicated cache system plugin for your site, you must exclude this page from this kind of plugin.

  7. Gabriel Cunha
    Member
    Posted 1 year ago #

    I deactivate the plugin wp super cache, but staying offline when the streaming is on. I don't understand this.

  8. sash2012
    Member
    Posted 1 year ago #

    Deactivate all plugins (except the livetv bundle plugin). I had some problems with old unupdated plugins.

    But I have no idea what the problem could be... and how to fix it... sorry

  9. Gabriel Cunha
    Member
    Posted 1 year ago #

    I make all atualization and I deactivate all plugin and staying show off when is on.

  10. Gabriel Cunha
    Member
    Posted 1 year ago #

    Actualization = Uptade - I wrote wrong! hahaha sorry

  11. Gabriel Cunha
    Member
    Posted 1 year ago #

    Now the plugin are displaying two error that was not displaying before, you can saw it here: http://vti-gaming.com.br/wordpress/stream/

    There's something else to do? Like change some php, or other something else then configuration itself?

  12. KwarK
    Member
    Plugin Author

    Posted 1 year ago #

    No, nothing to change (except css for some themes).

    possible problems

    1 Maybe your site (with 7389 like from facebook) have reached rapidely the sum of maximum request on twitch Api if you have disable the cache system and so if many visitors have clicked on live stream page until your test and implementation.

    The limit is fixed by twitch with a maximum of 45 request for 5 minutes without Api key.

    Choose a minimal cache time of 5 minutes for your site in your dashboard > liveTV Bundle > General livestream (cache time option), is a good choice.

    ps: I don't know the ban time by twitch/justin Api. but Google known maybe this.

    2 The event you try to share is a competitive big challenge I think. And I don't know if a owner of a channel (or Twitch) can be disable the authorization to share on other site ???

    3 Normally If the plugin return "offline", therefore the official API twitch/justin returns "offline" otherwise it is impossible the plugin return "offline" for nothing (unless a spelling error is made on your profile for this channel, unless I made ​​a mistake in my code).

    4 Try to add a 2nd, 3rd,... channel (try with the same channel before others) to view if I have made a mistake in my code.

  13. KwarK
    Member
    Plugin Author

    Posted 1 year ago #

    You can use a cache system plugin but you must exclude the stream page from this kind of plugin (this kind of options exists in page options of these plugins)

    e.g. for your site, you must exclude

    /stream/

    After this kind of changes, it is necessary to delete the content of the /cache/ folder manually (from these cache plugins) to view more rapidly your changes. These plugins re-creates automatically all the necessary file and folder. Don't worry.

  14. Gabriel Cunha
    Member
    Posted 1 year ago #

    As possible you add me on skype if the problem continue?

  15. Gabriel Cunha
    Member
    Posted 1 year ago #

    Well when I deactivated some inutil plugins and deleted URL of facebook page.

    In the website show that error/warning : Warning: file_get_contents() [function.file-get-contents]: URL file-access is disabled in the server configuration in /home/blizzedito/public_html/wordpress/wp-content/plugins/livetv-bundle/page-frontend/page-livetreams.php on line 634

    Warning: file_get_contents(http://api.justin.tv/api/stream/list.json?channel=artien,) [function.file-get-contents]: failed to open stream: no suitable wrapper could be found in /home/blizzedito/public_html/wordpress/wp-content/plugins/livetv-bundle/page-frontend/page-livetreams.php on line 634

  16. Gabriel Cunha
    Member
    Posted 1 year ago #

    I deactivated the Facebook app, also my website is hidden on my website, so no visitors. I also deactivated the cache plugin (even when its turned on the stream page is excluded). I tryed my own livestream, no diff., also all these livestream that I´m adding is from users who authorize ppll to embebed and share them.

  17. Gabriel Cunha
    Member
    Posted 1 year ago #

    Others exemple who I saw in http://e-srael.org/stream1/

  18. KwarK
    Member
    Plugin Author

    Posted 1 year ago #

    I have matched the problem

    file_get_contents(http://api.justin.tv/api/stream/list.json?channel=artien,)

    Sometimes, the official Api and this latest comma makes down stream.

    The 1.2.8 version is up to date and correct them

  19. KwarK
    Member
    Plugin Author

    Posted 1 year ago #

    Don't use sub-pages in some case.

    The plugin preg_match the url in use for the shortcode [livesOnline] to create some liberty of usage for your choice of the url/page name and to generate some php script but a rule is to use a different page for this shortcode (in fact in your site). Don't mix multiples sub-pages (with manual shortcodes included) with the shortcode [livesOnline] included in the parent page.

  20. KwarK
    Member
    Plugin Author

    Posted 1 year ago #

    A simple hack to use sub-menu without create sub-page is in Dashboard > Appearence > menu (if your theme support menu).

    To create a simple hack, you may add in the box "Custom link"

    @ url

    #

    and

    @ label

    name of your choice

    Click add and after you may add your pages in this menu and after move these pages buttons lightly to the right of name of your choice button to create your sub-menu with these pages buttons.

  21. KwarK
    Member
    Plugin Author

    Posted 1 year ago #

    Try also to change your file permission of /cache/ folder to 0755 with your ftp client

  22. Gabriel Cunha
    Member
    Posted 1 year ago #

    Hi, It's possible you add me on skype? Because I make what you said, but its not working.

  23. KwarK
    Member
    Plugin Author

    Posted 1 year ago #

    I'm not very fluent in english, I have regularly requested on a translator to make sure my English is bearable.

    A latest point, the plugin have some problem with buddypress.

  24. Gabriel Cunha
    Member
    Posted 1 year ago #

    No problem, I'm not fluent too. add me : gabrielsousa12 on skype

  25. Gabriel Cunha
    Member
    Posted 1 year ago #

    This website don't use Buddypress, I don't understand why not working, I tried a lot of things and stay with same problem.

  26. sash2012
    Member
    Posted 1 year ago #

    Hi,

    to fix this problem:

    Warning: file_put_contents(/home/mele/domains/e-srael.org/public_html/wp-content/plugins/livetv-bundle/cache/temp_1_live.html)

    Just create an empty temp_1_live.html file in the "livetv-bundle/cache" folder and set the CHMOD (Permission) to 777.

    I installed the Plugin on a fresh installation and had the problems.

    I dont know why but you should add the file as default in the plugin.

    Another point is: set the cache to 3 if you dont have added alot of streams yet. Remember: The message will disappear after 3 minutes and your online streams will be shown.

    Best regards,
    sash

  27. sash2012
    Member
    Posted 1 year ago #

    Other stuff:

    @ Gabriel:

    Warning: file_get_contents() [function.file-get-contents]: URL file-access is disabled in the server configuration in /home/blizzedito/public_html/wordpress/wp-content/plugins/livetv-bundle/page-frontend/page-livetreams.php on line 634

    There is a message that the access is disabled in the server configuration. So after using google you can find out that the problem is a deactivated "allow_url_fopen" in the php.ini file of your provider.

  28. Gabriel Cunha
    Member
    Posted 1 year ago #

    Sash, I will try. Later, I post the result.

  29. sash2012
    Member
    Posted 1 year ago #

    Okay

  30. KwarK
    Member
    Plugin Author

    Posted 1 year ago #

    It's the real problem that Sash explains http://bit.ly/OWyf6a

    If the php option is not activated on your "php engine" on server side, this php default function can not work.

    Thx Sash

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic

Tags

No tags yet.