WordPress.org

Ready to get started?Download WordPress

Forums

Liveblog
[resolved] Massive bug, I think (17 posts)

  1. johnkoetsier
    Member
    Posted 1 year ago #

    When you edit the Liveblog post via the backend, it deletes the entire liveblog you've done so far ...

    http://wordpress.org/extend/plugins/liveblog/

  2. Daniel Bachhuber
    Hand Built
    Plugin Author

    Posted 1 year ago #

    This is intended, as each liveblog update is stored as a comment on the original post.

    Is there behavior you'd suggest otherwise?

  3. johnkoetsier
    Member
    Posted 1 year ago #

    That's insane ... what if you want to add a featured image, or edit anything else?

    At very minimum, writers should be warned.

    And why should editing delete comments? Any post on any WP blog can be edited without deleting the comments on that post.

    Writing this up for VentureBeat, let me know if you have updates.

  4. Daniel Bachhuber
    Hand Built
    Plugin Author

    Posted 1 year ago #

    Oh, sorry, I misread your original comment as "when you delete the liveblog post via the backend".

    Editing the post shouldn't delete the comments. Can you confirm you're running trunk and aren't experiencing this issue?

    What edit did you make that caused the liveblog to be deleted?

  5. johnkoetsier
    Member
    Posted 1 year ago #

    3.4.1, no updates available.

    Edited the post to add a featured image, saved, boom, liveblog disappeared.

  6. Yuri Victor
    Member
    Posted 1 year ago #

    On trunk, I'm not experiencing this issue.

    The liveblog entries are pulled based on the post ID which doesn't change if the main entry is edited.

  7. Yuri Victor
    Member
    Posted 1 year ago #

    On 3.4.1., the posts disappear because they haven't been approved yet.

    This is fixed in 3.5 and an update for backwards compatibility is coming soon.

  8. johnkoetsier
    Member
    Posted 1 year ago #

  9. johnkoetsier
    Member
    Posted 1 year ago #

    And yes, editing in the backend kills the liveblog posts ... without warning.

  10. johnkoetsier
    Member
    Posted 1 year ago #

    Duplicated the issue.

  11. johnkoetsier
    Member
    Posted 1 year ago #

    YuriVictor: why would they need to be approved? I allow comments to go live, and I have no approvals process for posts on my blog.

  12. Yuri Victor
    Member
    Posted 1 year ago #

    @johnkoetsier The change to comments is an update in WordPress 3.5.

    Looks like the liveblog plugin has been made backwards compatible for 3.4.1 on github and the push will be available here on WordPress soon.

  13. Mohammad Jangda
    Member
    Plugin Author

    Posted 1 year ago #

    @johnkoetsier can you update to v1.1 and try again?

  14. varunkrish
    Member
    Posted 1 year ago #

    Hi Mohammad,

    Thanks for the quick 1.1 update. But still not working.

    Get a 404 error which I try to save a new live blog entry

    Firebug says the following url threw a 404 Not found

    domain.com/wordpress/test-4/liveblog/1/1346807291/

  15. varunkrish
    Member
    Posted 1 year ago #

    looks like custom permalinks are the culprit .

    I changed to the default ?p=post_id format and things work fine

  16. Mohammad Jangda
    Member
    Plugin Author

    Posted 1 year ago #

    @varunkrish try flushing your rewrite rules once again after changing to custom permalinks (Settings > Permalink, hit Save)

  17. Juan Diego Gonzales
    Member
    Posted 1 year ago #

    Thanks Mohammad! That last thing worked for me.

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic