WordPress.org

Ready to get started?Download WordPress

Forums

Liveblog
Error 404 (32 posts)

  1. Lutz.H
    Member
    Posted 1 year ago #

    Hi!

    I installed the plugin, integrated into a post and it appears. But when I type a live post and click "send", I always get the error message 404. I'm logged in of course. What shall I do?

    Thanks in advance!

    http://wordpress.org/extend/plugins/liveblog/

  2. Daniel Bachhuber
    Hand Built
    Plugin Author

    Posted 1 year ago #

    Does this issue persist with other plugins deactivated? Any JavaScript errors on the page? Can you provide some screenshots of before and after?

  3. Matteo Tirelli
    Member
    Posted 1 year ago #

    Hi There!
    Same problem here... I get error message 404 using a custom permalink structure. If i switch to default permalink structure plugin works correctly.
    Any idea to solve it?
    Many thanks and compliments for this usefull plugin! Very nice work!

  4. Matteo Tirelli
    Member
    Posted 1 year ago #

    just to complete my previous comment: I'm running WordPress 3.4.2 with current Liveblog plugin (same problem testing liveblog-v1.1.0-32)
    Thanks in advance for any hint!
    Matteo

  5. ninathing
    Member
    Posted 1 year ago #

    I'm having the same problem, does not work at all with custom permalink structure. Same setup as Matteo, same exact error even with all other plugins deactivated.

  6. Joost
    Member
    Posted 1 year ago #

    Here another one. On my test setup everything works fine. The one thing that's different is that I use w3 total cache, with minify. The last bit seems to cause the problem, as when loading the page, it says:

    TypeError: wp.Uploader is not a constructor
    source: http://xxx.nl/wp-content/w3tc/min/752126c9.17cb0a.js
    line: 22

    After that, only 404s

  7. fredcampagna
    Member
    Posted 1 year ago #

    Does anyone know a workaround for this? Really want to liveblog, but, now I'm getting the 404 error. Any decent alternative plugins?

  8. lucasreino
    Member
    Posted 1 year ago #

    Hi,

    Same problem, to solve you have to change the permalinks... Use the default.?p=123

  9. Joost
    Member
    Posted 1 year ago #

    From an SEO point of view that is not really the smart thing to do... Just hope that they fix this in the next version. Could have used it with the US elections...

  10. StripStuff
    Member
    Posted 1 year ago #

    I have the same issue.
    Any permalinks used other than the default, throws a 404.

    As others have mentioned, this is an awesome piece of software that i am really looking forward to using, but is near pointless if it cant be used with SEO optimized URL's.

    Hopefully someone has a workaround/fix sometime soon!

  11. Kargo
    Member
    Posted 1 year ago #

    Please fix this!

    I have a custom permalink setup and its not working.

  12. Mohammad Jangda
    Member
    Plugin Author

    Posted 1 year ago #

    Can you try the latest version from Github: https://github.com/Automattic/liveblog/archive/master.zip

    We pushed a few changes to how Liveblog endpoints are generated and that might fix most of the issues noted here.

  13. Matteo Tirelli
    Member
    Posted 1 year ago #

    I tried the latest version from Github. Unfortunatly I got always a 404 Error when publishing a new liveblog entry

  14. Nikolay Bachiyski
    Key Master
    Plugin Author

    Posted 1 year ago #

    Matteo,

    Could you give us a bit more information about your current permalink structure, so that we can reproduce the problem?

  15. Matteo Tirelli
    Member
    Posted 1 year ago #

    Sure!
    My permalink structure is: /index.php/%category%/%year%/%postname%/
    index.php is a workaround to solve a problem we have on our hosting: (no modrewrite module installed)

  16. vrgraphica
    Member
    Posted 1 year ago #

    Still showing 404 error while sumitting it, i am using w3 total cache and my permalink structure is /%category%/%postname%-%post_id%

  17. mazin
    Member
    Posted 1 year ago #

    Hey guys I solved the problem by just changing my permalink structure option!

    In your Dashboard go to:

    Settings
    Permalinks

    then you will find 6 different options of permalink structures. Try these different structure options one by one until the problem gets solved!

    That's how I solved mine! good luck!

  18. Joost
    Member
    Posted 1 year ago #

    That's not so much a solution as a work around. For me, for example, is changing the permalink structure of the site, affecting 10s of thousands of articles, the worst solution possible.

    The problem should be fixed in the code of the plugin, so for now just a subset of WP installs can use this plugin.

    ("Should" like in that it would be the best solution possible. Of course the plugin makers can do whatever they wish, since it is something that they provide free of charge.)

  19. Nikolay Bachiyski
    Key Master
    Plugin Author

    Posted 1 year ago #

    Hey everybody,

    I tried on several installs with all the permalink structures mentioned above and it always works for me.

    I'd really like to help you. Here are a couple ideas:

    0. Could you disable any caching plugins for a bit?
    1. Could you install the Rewrite Rules Inspector plugin and see if there are any missing rewrite rules? A screenshot of the rules page will be useful.
    2. If anybody is willing to give access to a server with 404-ing liveblog, I'd be happy to have a look.

  20. Matthew Bennett
    Member
    Posted 1 year ago #

    Hi, this has happened to me now too. Worked fine when I first installed it yesterday (with permalinks as /%post_id%/%postname%/). Had to sort out another issue so disabled and re-enabled all the plugins and now liveblog only works with the default ?p=xxx permalinks. Very strange. Even on the same test live blog page I created yesterday. I tried installing the Git version zip as well but that didn't solve the problem. Some strange combination of deactivating Liveblog & W3 Total Cache and reactivating them did. Now seems to be working again with permalinks in place. Weird.

  21. Nikolay Bachiyski
    Key Master
    Plugin Author

    Posted 1 year ago #

    In general liveblog should be working with W3 Total Cache, but we need to test some more.

    We'll try to track down the issue for the next version: https://github.com/Automattic/liveblog/issues/91

  22. comicref
    Member
    Posted 1 year ago #

    It seems there's a conflict with the plugin Events Manager. Liveblog has served me well several times. I installed EM yesterday and got 404 error codes while trying to live blog The Oscars. It works fine after deactivating EM.

  23. renatokeuller
    Member
    Posted 1 year ago #

    It really is the most amazing plugin I've ever met, but ironically, I can not use it due to the simple fact of using permalinks: http://www.meusite.com/categorias/noticias-locais/

    The worst thing is that I really do not see any interest on the part of the authors to find a solution and gives no clear answers here in support.

    Lords of the plugin authors, at least they can tell us when it will be ready a version that the plugin works properly? If the problem is the fact that it is free, then create a pro version, since that works, we will have great pleasure in buying it.

  24. Djelibeybi
    Member
    Posted 1 year ago #

    Yeah, doesn't work with permalinks for me either. If I use the default ?p=XX it works fine. I had W3 Total Cache installed before, but it had been deactivated and deleted before I installed Liveblog.

    When I look at the rules with the Rewrite Rules Inspector, I can see that all four rules for liveblog are missing their source. I've tried enabling the plugin at the network level and at the individual site level, but neither makes any difference.

  25. brohism
    Member
    Posted 1 year ago #

    It may help if those experiencing the issue can post details about their server environment. What web server and version are you using (Apache, NginX, etc.). What version of PHP? Perhaps also include your rewrite rules.

  26. jipido
    Member
    Posted 1 year ago #

    Hej,
    I get the same 404-error with the plugin and my speaking-permalink option, but i don't use any caching plugin.

    I use a standard apache-webspace. YOu can check my phpconfiguration at http://bolzplatzheld.de/phpinfo.php

    here is my htaccess:
    RedirectMatch 301 ^/([0-9]{4})/([0-9]{2})/(.*)$ http://bolzplatzheld.de/$3
    # BEGIN WordPress

    <IfModule mod_rewrite.c>
    RewriteEngine On
    RewriteBase /
    RewriteRule ^index\.php$ - [L]
    RewriteCond %{REQUEST_FILENAME} !-f
    RewriteCond %{REQUEST_FILENAME} !-d
    RewriteRule . /index.php [L]
    </IfModule>

    # END WordPress

    if it's helpful, i can give you an user to liveblog something. please contact me.

    Thanks for your help

  27. cnrr
    Member
    Posted 1 year ago #

    Same here and sometime parsererror :(

  28. joostpass
    Member
    Posted 1 year ago #

    Hi, have the same problem since I installed Liveblog yesterday

  29. joostpass
    Member
    Posted 1 year ago #

    /%year%/%category%/%postname%/
    It run as a permalink of substitution

    but something very weird :

    /%category%/%year%/%postname%/
    If you move "category" in the permalink like this, it don't works anymore...

    I'm hurry that the developers of Liveblog publish an update

  30. Kargo
    Member
    Posted 1 year ago #

    Getting the exact same issue, never happened previously up until recently.

    http://i.imgur.com/LYJDhJ3.png

    Here is the coding of my page template although I do not think there is an issue with it as it hasn't changed since it worked.

    http://pastebin.com/BevGW5FW

    The error console shows this if its any help.

    "Failed to load resource: the server responded with a status of 404 (Not Found) http://escxtra.com/2013/03/live-blogging-test-2/liveblog/crud"

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic

Tags