WordPress.org

Ready to get started?Download WordPress

Forums

Live Blogging
Twitter not working? (15 posts)

  1. C W
    Member
    Posted 3 years ago #

    The plugin looks great, but I can't seem to get it to connect to Twitter. On the settings screen, all I get is the message "You are not yet connected to Twitter. Click the image below to connect", followed by "Unable to connect to Twitter at this time".

    Any ideas?

  2. chrisnorthwood
    Member
    Plugin Author

    Posted 3 years ago #

    Sounds like you were trying when Twitter down, or your webhost blocks outgoing connections

  3. C W
    Member
    Posted 3 years ago #

    Must be the latter, as Twitter's up. Thanks - I'll look into it.

  4. C W
    Member
    Posted 3 years ago #

    Working like a charm now - great plugin!

    Just one suggestion while I'm about it: it'd be good to have the ability to customise the tweets sent out through the plugin. I know that I could just go into Twitter and post my own tweets, but it would be a neat feature nevertheless as sometimes the first 139 characters of a live blog post aren't going to be completely coherent on their own (or I might want to post only the first 80 characters of a particular post).

  5. C W
    Member
    Posted 3 years ago #

    Actually, spoke a bit too soon. I tested this out on a host that I know allows outgoing connections - other plugins that post to Twitter from WordPress, like WordTwit, work just fine - but no updates have been sent to the Twitter account that I selected.

    [I set up the live blog on a WordPress page (http://www.mediaspy.org/report/live-blog/) and it should have been sending tweets to http://twitter.com/cyrilwashbrook.]

  6. chrisnorthwood
    Member
    Plugin Author

    Posted 3 years ago #

    I can't diagnose it without any more information really - is OAuth set up correctly, etc, etc... Twitter posting works fine on my test blog (and no-one else has reported this bug), so there must be something about your setup that's stopped it working

  7. C W
    Member
    Posted 3 years ago #

    I don't doubt that there's a way to get it to work, but I'm pretty sure it's got nothing to do with the general site/WP setup. I've now tested it on three servers - our main site plus two other places - that I know allow connections with Twitter. Just to make sure, I used fresh installations of both WordPress 3.0.1 and 3.0.4, and I tried installing them both in the root and in a sub-directory.

    Still nothing's happening - which suggests either that there's a setup problem which coincidentally exists on all of those servers and installations, or there's something a bit deeper at play. I'll continue to try things out: everything else about this plugin is working great, but it's the Twitter integration that I really need. :(

  8. chrisnorthwood
    Member
    Plugin Author

    Posted 3 years ago #

    On the settings page, it definitely says "You are already connected to Twitter. Click the image below to change the account you are connected to." - and the 'Enable Twitter' box is checked right? (best to check the simple stuff first)

    If that doesn't work - and you're comfortable with PHP code - then you might want to try and debug the issue yourself (it works perfectly for me, I just tested it just now), then the appropriate place to look is around line 879 in live-blogging.php. You may want to do something like add the following:

    var_dump($tweet);
    die();

    in between lines 879 and 880, and then when you post a post, see what the output of that is.

  9. C W
    Member
    Posted 3 years ago #

    Yep, it does have that message. Thanks for the suggestion: I'll have a poke through the code this morning and see where that takes me.

  10. C W
    Member
    Posted 3 years ago #

    Hi Chris, I used var_dump to diagnose, and it turns out the problem was in the authentication. So I downloaded the twitteroauth library directly from github, re-uploaded the files and now it seems to be working.

    Not sure precisely what was wrong with the twitteroauth.php packaged in the plugin download: I noted that the twitteroauth.php in the plugin was about 50 bytes larger than the one I downloaded from github, but didn't check for the precise differences. But whatever it was, it fixed the problem.

    Thanks for all the help!

  11. chrisnorthwood
    Member
    Plugin Author

    Posted 3 years ago #

    Odd. Glad that you've got it to work though.

  12. Jeremy Sarber
    Member
    Posted 3 years ago #

    I tried var_dump and it returned "Null."

    I used Cyril Washbrook's solution but it didn't work for me. I still get "Unable to connect to Twitter at this time."

    Any other suggestions?

  13. chrisnorthwood
    Member
    Plugin Author

    Posted 3 years ago #

    The Twitter OAuth credentials have changed. I've just pushed a new version with only that change.

  14. Jeremy Sarber
    Member
    Posted 3 years ago #

    Great. I'll update and give it another try. Thank you.

  15. Jeremy Sarber
    Member
    Posted 3 years ago #

    It worked for me as of 3/21/11. Thanks again.

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic