WordPress.org

Ready to get started?Download WordPress

Forums

List category posts
[resolved] Extra " added to ul tag (24 posts)

  1. Eric Sopp
    Member
    Posted 2 years ago #

    I noticed an extra " mark being added to the UL tag. I took some screen shots of the fix:

    before view: http://screencast.com/t/DglG7mnVw
    see firebug: http://screencast.com/t/hZ3FvlunTnK
    see widget settings: http://screencast.com/t/tiEORtPklK
    see CatListDisplayer.php: http://screencast.com/t/p0HioYbY
    after view: http://screencast.com/t/F78lf603hyvb

    http://wordpress.org/extend/plugins/list-category-posts/

  2. picandocodigo
    Member
    Plugin Author

    Posted 2 years ago #

    Thanks ideric! Just released a bugfix release v0.20.1 without this extra ". Thanks for your contribution!

  3. Eric Sopp
    Member
    Posted 2 years ago #

    Pleasure! Thank you for keeping the plugin alive...

    Check it out in action here (see sidebar):
    http://www.financialsocialwork.com/center

  4. Start1
    Member
    Posted 2 years ago #

    Updated, but something went wrong. The hole site got the footer-color, and tags= didn't work. Strange. Had to go back to 0.19.3 again :(

  5. Andreas Beer
    Member
    Posted 2 years ago #

    The bug is still present.
    First link read
    <a href=" "="" akten-vom-placida-viel-berufskolleg-lagen-an-der-autobahn="" 07="" 10="" 2011="" smmp.de="" http:="">
    second link looks normal
    <a href="http://smmp.de/2011/10/05/musik-und-kunst-mit-kindern/">Musik und Kunst mit Kindern</a>

  6. Frank Gomez
    Member
    Posted 2 years ago #

    Yes have bug too. First item in list of posts the post title link is disabled and not part of the unordered list. Reverting to old version.
    Theme "Headway Theme"

  7. ortixia
    Member
    Posted 2 years ago #

    i am having trouble as well after updating this morning. My 'class' is not showing up. On my pages before the list I am getting the following code that shows up: <ul class=“myclass>

    you can see an example on our homepage at http://www.terralingua.org

  8. Frank Gomez
    Member
    Posted 2 years ago #

    PS: New version seems to work fine in another website built with Weaver Theme - My server is PHP 5 but I used version 17.X of your plugin to fix problem.

    Website it isn't working (but replaced plugin with older version)
    http://sarasotabay.org/photo-gallery/
    Website where it is working:
    http://foodaddictioninstitute.org/WP/what-is-food-addiction/questions-and-answers/

  9. ortixia
    Member
    Posted 2 years ago #

    i added the " in the Catlistdisplayer.php according to Ideric's screenshot, and this fixed the trouble.

  10. picandocodigo
    Member
    Plugin Author

    Posted 2 years ago #

    Ok, the error was the extra " as ideric first pointed out. I removed it on version 0.20.1, but if you specify a class for the plugin, the " didn't get closed like ortixia showed: <ul class="myclass>

    I placed the " correctly now. Now, regarding Start1's and Andrea's bugs, could you be more specificas to when / how this is happening?

    Please, everyone try out the latest release: 0.20.2 and sorry for the dumb mistake on version 0.20.1.

    Thanks!

  11. picandocodigo
    Member
    Plugin Author

    Posted 2 years ago #

    UPDATE: I'm seeing Andrea's bug now, I'll fix it ASAP and release a new version.

  12. picandocodigo
    Member
    Plugin Author

    Posted 2 years ago #

    Ok, version 0.20.2 is up and ready to update. It addresses the " and no link on the first post issues. Please update and let me know if it's working correctly for all of you.

    Thanks!

  13. Start1
    Member
    Posted 2 years ago #

    Better, but tags=xxx dos not work here with the latest version

  14. Start1
    Member
    Posted 2 years ago #

    But tag=xxx do work. Can you change it back to tags. Have a lot of posts with tags

  15. Start1
    Member
    Posted 2 years ago #

    I also get something wrong when i just use [catlist], it does not print out the latest posts as it used to, but the latest posts from the first tag.

  16. Start1
    Member
    Posted 2 years ago #

    [catlist author=40] also print out the latest 5 from the first tag in the post.

    The only thing that's working on my site is [catlist id/name=]

  17. Frank Gomez
    Member
    Posted 2 years ago #

    Thank you, 20.2 is working well for me.

  18. picandocodigo
    Member
    Plugin Author

    Posted 2 years ago #

    Start1, I changed the functionality back to showing the latests posts when using only [catlist] in version 0.20.3 (now available). Please read the notes on usage for more specific info.

    I'm looking into the 'tags' issue now.

    Thanks!

    Fernando

  19. mnplatypus
    Member
    Posted 2 years ago #

    How do I get back to the previous version that worked? I use the tags feature extensively and my site has a lot of missing bits now :(

  20. Start1
    Member
    Posted 2 years ago #

    @mnplatypus. Download 0.19.3 here https://wordpress.org/extend/plugins/list-category-posts/download/

    Delete the new pluginversion from admin->plugins and uppload 0.19.3. Then everything should be OK again.

    But I'm shore @fernandobt is fixing the a new version that works soon.

  21. picandocodigo
    Member
    Plugin Author

    Posted 2 years ago #

    Thanks for your patience guys!
    I managed to squeeze some time into a bugfix release today, please test version 0.20.4 and check if the tags issue is fixed. I'm not having much time for tests on every release, so any volunteers are more than welcome :)

    Thanks!

  22. Start1
    Member
    Posted 2 years ago #

    Thank You man :) The tags= works :)

  23. mnplatypus
    Member
    Posted 2 years ago #

    Yay! Mine works again now :) Thank You!

  24. picandocodigo
    Member
    Plugin Author

    Posted 2 years ago #

    Great guys! I've marked this issue as resolved.

    Please consider voting on the compatibility box on the plugin's page when a new version is out and you've tested it's working properly.

    I'll keep on working on some other issue which arose recently and other small fixes.

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic