WordPress.org

Ready to get started?Download WordPress

Forums

List category posts
can't activate upgraded plugin (3 posts)

  1. Ruth Maude
    Member
    Posted 3 years ago #

    I can't activate the plugin now

    Parse error: syntax error, unexpected T_STRING, expecting T_OLD_FUNCTION or T_FUNCTION or T_VAR or '}' in /wp-content/plugins/list-category-posts/include/CatListDisplayer.php on line 9

  2. daitya
    Member
    Posted 3 years ago #

    Which version WordPress are you using? Which version of PHP is on your server? Are you reporting this error with the latest version of the plugin (v .18.3)?

    If the previous version was working for you, you can revert to it. Download previous version from http://wordpress.org/extend/plugins/list-category-posts/download/.

    Otherwise, from the documentation (see FAQ) on the plugin's site, it appears that this error is due to incompatibility with PHP 4. The plugin author, Fernando Briano, has addressed the issue over at wordpress.stackexchange.com (http://wordpress.stackexchange.com/questions/9338/list-category-posts-plugin-upgrade-fails-fatal-error/9340#9340).

    Hope this is helpful.

  3. picandocodigo
    Member
    Plugin Author

    Posted 3 years ago #

    Thanks daitya, you're on the way to becoming one of List Category Posts' most valuable user :P

    dandelionweb, as daitya said, I've addressed this issue and I included this error on the FAQ.

    You should consider updating your server to PHP5 since WordPress will stop giving support to PHP4 in the upcoming version 3.1.

    Thanks dandelionweb for reporting and daitya for the support :D

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic