WordPress.org

Ready to get started?Download WordPress

Forums

LinkedIn Profile Synchronizer Tool
[resolved] Fatal error (22 posts)

  1. Jay Collier
    Member
    Posted 1 year ago #

    I received this error after install in 3.4.2:

    Fatal error: Cannot redeclare class OAuthRequest in /home/[account-removed]/public_html/wp-content/plugins/lips/php-oauth/OAuthRequest.php on line 40

    http://wordpress.org/extend/plugins/lips/

  2. bastb
    Member
    Plugin Author

    Posted 1 year ago #

    Hi,

    I assume you're using version 0.8.8 of the plugin. Which other plugins are installed and when are you getting this error?

    Thanks, Bas

  3. Jay Collier
    Member
    Posted 1 year ago #

    I am using 0.8.8. I did a search for "OAuthRequest" and found references in the following plugins:

    wp-rss-poster
    tweet-blender
    google-analytics-for-wordpress

  4. bastb
    Member
    Plugin Author

    Posted 1 year ago #

    Ah thanks, I'll try to release a new version

  5. bastb
    Member
    Plugin Author

    Posted 1 year ago #

    Please update to version 0.8.9 and let me know if this fixed the issue.

  6. Jay Collier
    Member
    Posted 1 year ago #

    Thank you! No error now. Great!

  7. Jay Collier
    Member
    Posted 1 year ago #

    However, after I get my token and secret and enter them into the settings screen, when I click Save, I get this error:

    There is a problem getting an authorization code from LinkedIn®:

    Unexpected result from the server "https://api.linkedin.com/uas/oauth/requestToken" (401) while requesting a request token
    This may be caused by incorrect OAuth Identification, a slow internet connection or a problem at LinkedIn®. Retry in a couple of minutes if you did not change anything

    I've tried it over the course of about 10 minutes with no luck.

  8. bastb
    Member
    Plugin Author

    Posted 1 year ago #

    That's weird. Can you see if there's anything special in the webserver error logging?

  9. Jay Collier
    Member
    Posted 1 year ago #

    Nothing in the error logs.

  10. bastb
    Member
    Plugin Author

    Posted 1 year ago #

    Just to be sure I understand this (new) problem:

    • You've installed & activated LiPS version 0.8.9.
    • You clicked Tools -> LinkedIn Profile Sync and you got a section in which you copied the OAuth Token and secret.
    • You clicked "Save" and the error popped up?

    I've seen this 401 error when I mixed the Token and Secret. Please click "Forget OAuth" and copy them from the LinkedIn developer page.

  11. Jay Collier
    Member
    Posted 1 year ago #

    Correct, except for one thing.

    When I entered the Token and Secret, I clicked Save and I did see the "LinkedIn Data Access and Profile Synchronization" screen. After I selected a Profile Page and clicked Save a second time, then I saw the error.

    I copied the "OAuth User Token" and the "OAuth User Secret" directly from the developer page.

    Also, I only filled out the fields on the LI Application Details page that has asterisks.

  12. bastb
    Member
    Plugin Author

    Posted 1 year ago #

    Thanks, the steps you're describing is how it's supposed to work.

    Also, I only filled out the fields on the LI Application Details page that has asterisks.

    Should not really be a problem. Did you select "Development" as Live Status?

    Please click "Forget OAuth" on the plugin configuration page and open the LinkedIn Developer Network Application Details page again. Copy the value of API Key found on the LI Application Details page to the OAuth Token field found on the LinkedIn Profile Synchronization Tool section and copy the value of the Secret Key to the OAuth Secret and click Save again, then try to fetch your profile again.

  13. Jay Collier
    Member
    Posted 1 year ago #

    Bingo. By switching to the other set of credentials ...

    API Key
    Secret Key

    ... rather than ...

    OAuth User Token
    OAuth User Secret

    ... I did get to the next dialog box, which says:

    The plugin needs to be authorized to access your data. Click the Authorization Page link, grant access and paste the security code in the textbox:
    By visiting the LinkedIn Authorization page, pasting the security code here and clicking "Fetch" you allow the tool to:
    Read your LinkedIn® profile data and modify a page on this host using a template
    Store the profile data on this host

    I clicked on the link to the authorization page, allowed access, received a five digit number, copied it into the dialog box, and the process ran.

    However, I'm only seeing Education, none of the other sections.

    http://jaycollier.net/linkedin/

  14. bastb
    Member
    Plugin Author

    Posted 1 year ago #

    Thanks. Could you let me know which tokens you were using? I'll use it update the documentation.

    I've reviewed http://jaycollier.net/linkedin/resume and I can see only the first position being added. Can you review the apache server error logging to see if there are error messages?

    I can dig a little deeper, but I'll need a debug page for that. You can create a debug page from the Development Settings section found in the LinkedIn Profile Synchronization page, checking Debug Data On-a-Page and selecting the page you want to write the profile data to. Synchronize your profile again and drop me an email through http://www.tenberge-ict.nl/contact/english/. I'll tell you what to do by email.

  15. bastb
    Member
    Plugin Author

    Posted 1 year ago #

    I've not received a message, so I guess the problem is resolved. Feel free to reopen this post, create a new one or contact me when you experience problems.

  16. Jay Collier
    Member
    Posted 1 year ago #

    Since this feature isn't as important as others I'm rolling-out, I just uninstalled and and will try again in future. Not necessarily resolved for me, but you can close the ticket.

  17. bastb
    Member
    Plugin Author

    Posted 1 year ago #

    Please let me know when you're giving the plugin a new try. I would really like to find the reason why only the first position was added, specially because it does not occur on my own profile.

  18. Jay Collier
    Member
    Posted 1 year ago #

    Will do!

  19. manthonylibrizzi
    Member
    Posted 1 year ago #

    Hi... I've read through this thread, but have arrived at the following errors once I click the Authorization Page Link:

    Warning: Invalid argument supplied for foreach() in /home/content/88/8443988/html/manthonylibrizzi/wp-content/plugins/lips/lips.php on line 1834

    Warning: file_put_contents(/home/content/88/8443988/html/manthonylibrizzi/wp-content/uploads/lips/200x200_D6MJDMa_s4.jpeg) [function.file-put-contents]: failed to open stream: Permission denied in /home/content/88/8443988/html/manthonylibrizzi/wp-content/plugins/lips/lips.php on line 1915

    Warning: file_put_contents(/home/content/88/8443988/html/manthonylibrizzi/wp-content/uploads/lips/40x40_D6MJDMa_s4.jpeg) [function.file-put-contents]: failed to open stream: Permission denied in /home/content/88/8443988/html/manthonylibrizzi/wp-content/plugins/lips/lips.php on line 1915

    Warning: Invalid argument supplied for foreach() in /home/content/88/8443988/html/manthonylibrizzi/wp-content/plugins/lips/lips.php on line 1792

    Warning: Cannot modify header information - headers already sent by (output started at /home/content/88/8443988/html/manthonylibrizzi/wp-content/plugins/lips/lips.php:1834) in /home/content/88/8443988/html/manthonylibrizzi/wp-includes/pluggable.php on line 876

    Please help to resolve.
    Many thanks,
    Anthony

  20. manthonylibrizzi
    Member
    Posted 1 year ago #

    Hello...

    Choosing different page options I now received the following errors:

    Warning: Invalid argument supplied for foreach() in /home/content/88/8443988/html/manthonylibrizzi/wp-content/plugins/lips/lips.php on line 1834

    Warning: Invalid argument supplied for foreach() in /home/content/88/8443988/html/manthonylibrizzi/wp-content/plugins/lips/lips.php on line 1792

    Warning: Cannot modify header information - headers already sent by (output started at /home/content/88/8443988/html/manthonylibrizzi/wp-content/plugins/lips/lips.php:1834) in /home/content/88/8443988/html/manthonylibrizzi/wp-includes/pluggable.php on line 876

    Please advise..

    Many thanks,
    Anthony

  21. bastb
    Member
    Plugin Author

    Posted 1 year ago #

    Hi Anthony,

    The permission denied errors are caused by an attempt to save a copy of your LinkedIn profile picture. This attempt fails, because the webserver is not allowed to write to the media folder. Which version of the plugin are you using?

    The error messages at line 1834 and 1792 are in the "Questions/ comments" thread. It boils down to the plugin breaking since the WordPress 3.5 upgrade and I just don't have enough time right now to resolve the problem. I'll look into it when I find the time and I hope that will be this week.

    Sorry for the inconvenience.

  22. manthonylibrizzi
    Member
    Posted 1 year ago #

    Thanks for your response and brief clarity. - I'm using version 0.8.11.

    Many thanks,
    Anthony

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic

Tags

No tags yet.