WordPress.org

Ready to get started?Download WordPress

Forums

Link Library
[resolved] Slow load after upgrading to 4.1.8 (18 posts)

  1. High Aspirations, Inc.
    Member
    Posted 4 years ago #

    I just finished updating to version 4.1.8 on http://www.tktcpa.com/links/ and notice that the pages are taking a long time to load. There seems to be a good deal of lag and the browser sort of locks up or freezes before it releases the page back to mouse control. I'm sorry, but it is hard to explain exactly what it is doing. The rest of the site's pages are loading normally. I have debug mode on. Any suggestions?

    http://wordpress.org/extend/plugins/link-library/

  2. Yannick Lefebvre
    Member
    Plugin Author

    Posted 4 years ago #

    Which browser are you using? I am visiting the page from my work using Firefox and it's pretty snappy. Even doing a Shift-F5 to force a full page refresh comes up quickly.

  3. High Aspirations, Inc.
    Member
    Posted 4 years ago #

    Thanks for taking a look at this. Just tried it myself with firefox and I agree the page loads perfectly. Unfortunately, in IE8 and Avant I'm still getting the lag I mentioned.

  4. Yannick Lefebvre
    Member
    Plugin Author

    Posted 4 years ago #

    This does not make sense. While I did a lot of back-end changes to give more flexibility on version 4.0 and higher, the display code is very similar to what it was before. So IE should not have gotten slower with updates.

  5. High Aspirations, Inc.
    Member
    Posted 4 years ago #

    I totally agree that it doesn't make sense, but we are talking about IE here so all bets are off in my experience. I have no explanation for what I am seeing. All I can say is that I have tested it with IE8 and Avant in two different locations, connecting to the net via two different ISPs (actually from two different states!) and am still seeing the lag. Those were machines running Windows 7. To be thorough, I loaded the site up on a Win XP machine and tested it in IE7 and Avant on there and am seeing the lag there as well. Do you see it at all in IE or another browser?

  6. Yannick Lefebvre
    Member
    Plugin Author

    Posted 4 years ago #

    One thing I can think of is that I see that the thumbnails are currently always fetched from thumbshots.org. You might want to try using the generate thumbnails button to get the files from thumbshots.org once, then uncheck the box that gets them to be generated from thumbshots each time. Perhaps something in IE takes more time in fetching the files from the remote server.

  7. High Aspirations, Inc.
    Member
    Posted 4 years ago #

    I did as instructed, created the link-library-images directory, gave it 777 permissions, and generated the thumbnails. When I did that, I received a bunch of errors (guessing one for each link on the site) that said:

    Warning: file_get_contents(http://open.thumbshots.org/image.aspx?url=https://taxpackagesupport.com/(S(2wso4w45g2whrbq1ro2f5zrf))/k1SupportHome.aspx) [function.file-get-contents]: failed to open stream: no suitable wrapper could be found in /home/content/t/k/t/tktcpa/html/wp-content/plugins/link-library/link-library.php on line 360

    Line 360 of my link-library.php file is "$imagedata = file_get_contents($genthumburl);" The link-library-images directory now has files in it but they are all 0kb. I unchecked the "Use Thumbshots.org for dynamic link images" box and loaded up the site and now there are no thumbshots at all (which I expected since the files are 0kb) but there is still a delay.

    I left the site like this so that you can see it - http://www.tktcpa.com/links/. Debug mode is still on.

  8. Yannick Lefebvre
    Member
    Plugin Author

    Posted 4 years ago #

    Well, the fact that the page is still slow without any images tells us that the problem was not related to fetching the external pages on thumbshots. And other pages on the site load fast so it seems like it's not an issue with other parts of the site.

    Honestly, I am kind of stumped by this one.

    As for images not being generated right, I think the problem is that your server's php install is not configured to allow access to external link:

    allow_url_fopen = On

    Check for this line on your server's php.ini if you have access to it.

  9. High Aspirations, Inc.
    Member
    Posted 3 years ago #

    Your php.ini update nailed the thumbnail problem and the site now has it's thumbnails back. Thank you.

    So, with you stumped on the slow page load, where does that leave us?

  10. Yannick Lefebvre
    Member
    Plugin Author

    Posted 3 years ago #

    I'll have to do some more research on that slow load issue. I will get back to having more time next week. Currently busy with Wordcamp Montreal preparations since I am presenting.

  11. High Aspirations, Inc.
    Member
    Posted 3 years ago #

    No problem. Please let me know what you find when you return and can work on this again. I hope your presentation went well.

  12. Yannick Lefebvre
    Member
    Plugin Author

    Posted 3 years ago #

    I think that the problem may be related to the fancybox script that I am using for RSS Previews. The stylesheet is currently being loaded even if you don't use that feature.

    I am going to be trying to switch to a different lightbox script tonight and we can then see if this helps. I will also try to avoid printing out the lightbox styles if they are not being used.

  13. Yannick Lefebvre
    Member
    Plugin Author

    Posted 3 years ago #

    The lightbox change that I tried last night for another user fixed performance issues with IE. I still need to nail down a couple more issues tonight before I release a new version. Stay tuned.

  14. Yannick Lefebvre
    Member
    Plugin Author

    Posted 3 years ago #

    Please try updating to version 4.3.2 and see if it resolves the hanging issue that you are seeing in Internet Explorer.

  15. High Aspirations, Inc.
    Member
    Posted 3 years ago #

    Thank you. I will make an attempt to install the new version early next week. I will post again as soon as I do.

  16. Yannick Lefebvre
    Member
    Plugin Author

    Posted 3 years ago #

    Have you been able to perform the update? Let me know if it resolved the "hang" issue that you were having.

  17. High Aspirations, Inc.
    Member
    Posted 3 years ago #

    I'm sorry, I never got to do the upgrade as planned as I got a new client that shook up my schedule! The best laid plans of web designers and all that, but I won't complain because it's a new client!

    I was able to upgrade tonight and the hang problem is completely GONE! I checked it in IE, Avant, and Firefox and the Link Library pages are now loading as expected.

    Thank you for the awesome work!

    Unfortunately, I notice that the rss links are not working, but I'm going to mark this item as resolved and start a new post on that item.

  18. Yannick Lefebvre
    Member
    Plugin Author

    Posted 3 years ago #

    Glad to hear this one is resolved. Sorry about the other issue. I will try to get to it in the next 2-3 days.

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic