WordPress.org

Ready to get started?Download WordPress

Forums

Link Library
Problems with 4.2.4 upgrade (4 posts)

  1. Mark
    Member
    Posted 3 years ago #

    Below is just a sample of the errors/warnings I'm getting in my log since upgrading to 4.2.4. On the front-end these messages are replacing the RSS feed content. Disabling link-library eliminates the errors. The plugin is currently disabled on my site:
    http://radford.ttacconnect.org/

    I'd appreciate any possible solutions as this is a great plugin.

    [19-Aug-2010 15:33:47] PHP Strict Standards: Non-static method SimplePie_Misc::absolutize_url() should not be called statically, assuming $this from incompatible context in /home/xxx/public_html/wp-content/plugins/link-library/simplepie.inc on line 14929
    [19-Aug-2010 15:33:47] PHP Strict Standards: Non-static method SimplePie_IRI::absolutize() should not be called statically, assuming $this from incompatible context in /home/xxx/public_html/wp-content/plugins/link-library/simplepie.inc on line 9103
    [19-Aug-2010 15:33:47] PHP Strict Standards: Non-static method SimplePie_Misc::is_isegment_nz_nc() should not be called statically, assuming $this from incompatible context in /home/xxx/public_html/wp-content/plugins/link-library/simplepie.inc on line 3730
    [19-Aug-2010 15:33:47] PHP Strict Standards: Non-static method SimplePie_Misc::array_unique() should not be called statically, assuming $this from incompatible context in /home/xxx/public_html/wp-content/plugins/link-library/simplepie.inc on line 5564
    [19-Aug-2010 15:33:47] PHP Strict Standards: Non-static method SimplePie_Misc::get_element() should not be called statically, assuming $this from incompatible context in /home/xxx/public_html/wp-content/plugins/link-library/simplepie.inc on line 14949
    [19-Aug-2010 15:33:47] PHP Notice: Undefined offset: 0 in /home/xxx/public_html/wp-content/themes/inove/sidebar.php on line 88
    [19-Aug-2010 15:33:47] PHP Notice: Trying to get property of non-object in /home/xxx/public_html/wp-content/plugins/buddypress/bp-core/bp-core-adminbar.php on line 79
    [19-Aug-2010 15:33:47] PHP Notice: Undefined index: blogs in /home/xxx/public_html/wp-content/plugins/buddypress/bp-core/bp-core-adminbar.php on line 73
    [19-Aug-2010 15:33:47] PHP Notice: Trying to get property of non-object in /home/xxx/public_html/wp-content/plugins/buddypress/bp-core/bp-core-adminbar.php on line 79
    [19-Aug-2010 15:33:47] PHP Strict Standards: Non-static method BP_Core_Notification::get_all_for_user() should not be called statically in /home/xxx/public_html/wp-content/plugins/buddypress/bp-core/bp-core-notifications.php on line 40
    [19-Aug-2010 15:33:47] PHP Notice: Undefined property: stdClass::$xprofile in /home/xxx/public_html/wp-content/plugins/buddypress/bp-core/bp-core-notifications.php on line 63
    [19-Aug-2010 15:33:47] PHP Notice: Trying to get property of non-object in /home/xxx/public_html/wp-content/plugins/buddypress/bp-core/bp-core-notifications.php on line 63
    [19-Aug-2010 15:33:47] PHP Notice: Undefined variable: renderable in /home/xxx/public_html/wp-content/plugins/buddypress/bp-core/bp-core-notifications.php on line 69
    [19-Aug-2010 15:33:47] PHP Notice: Undefined property: stdClass::$id in /home/xxx/public_html/wp-content/plugins/buddypress/bp-core/bp-core-adminbar.php on line 192
    [19-Aug-2010 15:33:47] PHP Notice: Undefined property: stdClass::$current_group in /home/xxx/public_html/wp-content/plugins/buddypress/bp-groups.php on line 237
    [19-Aug-2010 15:33:47] PHP Strict Standards: is_a(): Deprecated. Please use the instanceof operator in /home/xxx/public_html/wp-includes/script-loader.php on line 607

  2. Yannick Lefebvre
    Member
    Plugin Author

    Posted 3 years ago #

    Hi Mark,

    Were you using Link Library to produce inline RSS content on the page or using the RSS Preview mode?

    I did some changes to error reporting but might have messed up something in doing that.

    I will look into the problem tonight.

    Sorry for the trouble.

  3. Mark
    Member
    Posted 3 years ago #

    Thanks for the quick reply. I reactivated link-library so you can see what's happening on the front end. The RRS link content is populating the content area of the page (after listing the warning/errors in the header and in the widget area). You can see 3 sections of the page with link-library activated here:
    http://img.skitch.com/20100820-1qadif74fn4m7budp3snw1miy2.jpg
    http://img.skitch.com/20100820-chfns1sah9me1fugsn561d4ra7.jpg
    http://img.skitch.com/20100820-cmy6xdk7bmeudq9kasa7ahc233.jpg
    http://img.skitch.com/20100820-rx7bs82kchxdy79e1xp53hfc1e.jpg

    The same page live with link-library deactivated:
    http://radford.ttacconnect.org

    I'm not sure how the RRS Preview mode OR inline RSS content would be different. I've selected the RSS Preview on the backend but it looks like inline content on the frontend. Let me know which I'm using. Thanks for your help.

  4. Yannick Lefebvre
    Member
    Plugin Author

    Posted 3 years ago #

    Hi Mark,

    Thanks for the screenshots. Could you export your Link Library settings (bottom of admin page) and post the contents of the file here (or send them to me via my contact form at http://yannickcorner.nayanna.biz/contact-me if you prefer) so that I can know your exact configuration.

    Yannick

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic