WordPress.org

Ready to get started?Download WordPress

Forums

[resolved] [Plugin: Link Library] Link library search returns to home page (13 posts)

  1. venntom
    Member
    Posted 4 years ago #

    Hi,

    When using the Search function of the link library, it redirects to the home page? Any suggestions to remedy this behaviour?

    Thanks -

  2. Yannick Lefebvre
    Member
    Posted 4 years ago #

    I am really not sure what could be causing this. Do you have a link a page where you tried using the search feature so that I could take a look?

  3. venntom
    Member
    Posted 4 years ago #

    PLease have a look at the following links page:
    http://www.vennekens.be/?page_id=376

    Regards

  4. othniel77
    Member
    Posted 4 years ago #

    I'm Having The Same Troble my site is http://whiteraven.hostei.com/?page_id=122

  5. othniel77
    Member
    Posted 4 years ago #

    I reinstalled eveything but still get the same result my links page is at: http://whiteraven.hostei.com/?page_id=3

  6. Yannick Lefebvre
    Member
    Posted 4 years ago #

    Sorry for the last of response. I am terribly with work at the moment and will be until December 4th. I will not have time to investigate this issue until that time. Thanks for bearing with me until I start having back to work on this and my other plugins again.

  7. venntom
    Member
    Posted 4 years ago #

    To othniel77;
    Your links page search seems to work now.
    What did you do?

  8. othniel77
    Member
    Posted 4 years ago #

    I switched to a plugin called "WordPress-Link-Directory" it creates it's own Link Data Base Separate from the blogroll. he said

    Sorry for the last of response. I am terribly with work at the moment and will be until December 4th. I will not have time to investigate this issue until that time. Thanks for bearing with me until I start having back to work on this and my other plugins again.

    So I'm testing a few other plugins until he fixes the "Link library search returns to home page" Problem... I Like Link library alot....
    & That's the one I really want. I also am using "blogroll-google-cse" for my blogroll

  9. Yannick Lefebvre
    Member
    Posted 4 years ago #

    All right. Life is getting back to normal for me after attending a large trade show related to my work in Florida last week.

    I think I see what is happening. Both of your sites are not using clean Permalinks. They are set to use the default link structure (e.g. http://whiteraven.hostei.com/?page_id=3 instead of http://whiteraven.hostei.com/Links). Because of this, the search query string is not getting processed correctly by WordPress.

    I am not sure how to get around this problem. Have you not enabled other Permalinks settings because you were not aware of their existence of because they are not supported on your web hosting service? You can configure Permalinks in the WordPress admin under Settings.

    Let me know if this helps,

    Yannick

  10. venntom
    Member
    Posted 4 years ago #

    Yannick,

    Thanks for your reply.
    Unfortunately, I can only use the default permalinks setting.
    All other settings will result in 404 errors.
    I assume that this is either due to the fact that my provider is hosting on IIS or the fact that I would need to re-generate somehow the permalinks that wordpress is storing now (just saving them does not do this)...
    Although this is wordpress and not link library related, any advize on how to remedy this?

    Thanks -

  11. Yannick Lefebvre
    Member
    Posted 4 years ago #

    I will have to do some research to see how I could access the parameters when using the default mode. I will try to get back to you within the next few days. Sorry for the trouble.

  12. Yannick Lefebvre
    Member
    Posted 4 years ago #

    I think that I have successfully modified Link Library so that search and paging work with Permalinks set to Default. Please try to upgrade to 2.5.7 and let me know if this did the trick.

  13. venntom
    Member
    Posted 4 years ago #

    I have installed link library 2.5.8; I can now search with permalinks set to default. Problem solved.
    Thanks for your great support!

Topic Closed

This topic has been closed to new replies.

About this Topic