WordPress.org

Ready to get started?Download WordPress

Forums

Link Library
Empty Links (16 posts)

  1. dhoffmann
    Member
    Posted 3 years ago #

    Hi,

    after update to 4.9.1 from 4.85 my lists are empty with message "No links found". But in the category lists it still shows the correct number.

    http://www.celtic-rock.de/links/verzeichnis

    Best wishes and thx for great plugin.

    Daniel

    http://wordpress.org/extend/plugins/link-library/

  2. Yannick Lefebvre
    Member
    Plugin Author

    Posted 3 years ago #

    Hi Daniel,

    How did you upgrade to the latest Link Library version? Did you use the WordPress upgrade mechanism or did you upload the new files via FTP? If you did the latter, please try deactivating and reactivating the plugin since the data schema changed between versions.

    Yannick

  3. Yannick Lefebvre
    Member
    Plugin Author

    Posted 3 years ago #

    Also, if you can temporarily turn on debug mode under the Link Library general settings, it would allow me to see a bit more about what is happening in the background. Debug mode adds comments with some debug data to your page's output.

  4. dhoffmann
    Member
    Posted 3 years ago #

    Hi Yannick,

    yes that was the solution! Thx. Deactivating and activating turned it on asgain. Concerning your questions:

    a) I used the WordPress integrated update mechanism.
    b) Debug mode was on.

    Thanks again, I like link library!

    Best wishes

    Daniel

  5. Yannick Lefebvre
    Member
    Plugin Author

    Posted 3 years ago #

    Strange. The original automatic upgrade should have done the deactivation and reactivation. Not sure why this did not take place. Thanks for the update.

  6. roberthickling
    Member
    Posted 3 years ago #

    Hi, Yannick,
    I'm also getting "No links found." Any ideas?
    Thanks,
    Robert

  7. myselfhimself
    Member
    Posted 3 years ago #

    Hello,

    I have the same issue : I manage to show the available categories, but not the links in any of them.

    I'm using version 4.9.3 of your plugin on a 3.1 wordpress fresh install (actually both wordpress and the plugin have been downloaded today from wordpress.org).

    I have enabled debugging in the link-library admin form and here's the related HTML output :

    <p>liste des liens :&nbsp;
    <!-- Library Settings Info:Array
    (
        [num_columns] => 3
        [showdescription] => 1
        [shownotes] => 1
        [beforenote] => <td>
        [afternote] => </td>
        [beforeitem] => <tr>
        [afteritem] => </tr>
        [beforedesc] => <td>
        [afterdesc] => </td>
        [displayastable] => 1
        [beforelink] => <td>
        [afterlink] => </td>
        [showcolumnheaders] => 1
        [linkheader] => Application
        [descheader] => Description
        [notesheader] => Similar to
        [beforerss] => <td>
        [afterrss] => </td>
        [beforedate] => <td>
        [afterdate] => </td>
        [beforeimage] => <td>
        [afterimage] => </td>
        [beforeweblink] => <td>
        [afterweblink] => </td>
        [beforetelephone] => <td>
        [aftertelephone] => </td>
        [beforeemail] => <td>
        [afteremail] => </td>
        [beforelinkhits] => <td>
        [afterlinkhits] => </td>
        [order] => name
        [hide_if_empty] => 1
        [table_width] => 100
        [catanchor] => 1
        [flatlist] =>
        [categorylist] =>
        [excludecategorylist] =>
        [showrating] =>
        [showupdated] =>
        [show_images] =>
        [use_html_tags] =>
        [show_rss] =>
        [nofollow] =>
        [catlistwrappers] => 1
        [beforecatlist1] =>
        [beforecatlist2] =>
        [beforecatlist3] =>
        [divorheader] =>
        [catnameoutput] => linklistcatname
        [show_rss_icon] =>
        [linkaddfrequency] => 0
        [addbeforelink] =>
        [addafterlink] =>
        [linktarget] =>
        [showcategorydescheaders] =>
        [showcategorydesclinks] =>
        [settingssetname] => Default
        [showadmineditlinks] => 1
        [showonecatonly] =>
        [loadingicon] => /icons/Ajax-loader.gif
        [defaultsinglecat] =>
        [rsspreview] =>
        [rsspreviewcount] => 3
        [rssfeedinline] =>
        [rssfeedinlinecontent] =>
        [rssfeedinlinecount] => 1
        [rsscachedir] => /var/www/wordpress/wp-content/cache/link-library
        [direction] => ASC
        [linkdirection] => ASC
        [linkorder] => name
        [pagination] =>
        [linksperpage] => 5
        [hidecategorynames] =>
        [showinvisible] =>
        [showdate] =>
        [catdescpos] => right
        [catlistdescpos] => right
        [showuserlinks] =>
        [addnewlinkmsg] => Ajouter un nouveau lien
        [linknamelabel] => Nom du lien
        [linkaddrlabel] => Adresse du lien
        [linkrsslabel] => Flux RSS du lien
        [linkcatlabel] => Catégorie de liens
        [linkdesclabel] => Description du lien
        [linknoteslabel] => Notes du lien
        [addlinkbtnlabel] => Ajouter un lien
        [newlinkmsg] => Nouveau lien soumis
        [moderatemsg] => il apparaîtra dans la liste une fois modéré. Merci.
        [rsspreviewwidth] => 900
        [rsspreviewheight] => 700
        [imagepos] => beforename
        [imageclass] =>
        [emailnewlink] =>
        [showaddlinkrss] =>
        [showaddlinkdesc] =>
        [showaddlinkcat] =>
        [showaddlinknotes] =>
        [usethumbshotsforimages] =>
        [addlinkreqlogin] =>
        [showcatlinkcount] =>
        [publishrssfeed] =>
        [numberofrssitems] => 10
        [rssfeedtitle] => Link Library-Flux d\'informations généré
        [rssfeeddescription] => Description du flux d\'informations généré par \'Link Library\'
        [showonecatmode] => AJAX
        [addlinkcustomcat] =>
        [linkcustomcatlabel] => Catégorie soumise par l\\\\\\\\\\\\\\\'utilisateur
        [linkcustomcatlistentry] => Catégorie définie par l\\\\\\\\\\\\\\\'usager (définir ci-dessous)
        [searchlabel] => Search
        [dragndroporder] => 1,2,3,4,5,6,7,8,9,10,11,12
        [showname] => 1
        [cattargetaddress] =>
        [displayweblink] => false
        [sourceweblink] => primary
        [showtelephone] => false
        [sourcetelephone] => primary
        [showemail] => false
        [showlinkhits] =>
        [weblinklabel] =>
        [telephonelabel] =>
        [emaillabel] =>
        [showaddlinkreciprocal] =>
        [linkreciprocallabel] => Lien réciproque
        [showaddlinksecondurl] =>
        [linksecondurllabel] => Adresse secondaire
        [showaddlinktelephone] =>
        [linktelephonelabel] => Téléphone
        [showaddlinkemail] =>
        [linkemaillabel] => Adresse électronique
        [emailcommand] =>
        [sourceimage] => primary
        [sourcename] => primary
        [enablerewrite] =>
        [rewritepage] =>
        [storelinksubmitter] =>
        [maxlinks] =>
        [showcaptcha] =>
        [beforelinkrating] =>
        [afterlinkrating] =>
        [linksubmitternamelabel] => Nom de l\\\\\\\\\\\\\\\'utilisateur ayant soumis le lien
        [showlinksubmittername] =>
        [linksubmitteremaillabel] => Courriel de l\\\\\\\\\\\\\\\'utilisateur ayant soumis le lien
        [showaddlinksubmitteremail] =>
        [linksubmittercommentlabel] => Commentaire de l\\\\\\\\\\\\\\\'utilisateur soumettant le lien
        [showlinksubmittercomment] =>
        [addlinkcatlistoverride] =>
        [showlargedescription] =>
        [beforelargedescription] =>
        [afterlargedescription] =>
        [showcustomcaptcha] =>
        [customcaptchaquestion] => Est-ce que l\\\\\\\\\\\\\\\'eau bouillante est froide ou chaude?
        [customcaptchaanswer] => chaude
        [rssfeedaddress] =>
        [addlinknoaddress] =>
        [featuredfirst] =>
        [linklargedesclabel] => Large Description
        [showuserlargedescription] =>
    )
    -->
    
    <!-- Beginning of Link Library Output -->
    
    <!-- Link Query: SELECT distinct *, l.link_id as proper_link_id, UNIX_TIMESTAMP(l.link_updated) as link_date, IF (DATE_ADD(l.link_updated, INTERVAL 120 MINUTE) >= NOW(), 1,0) as recently_updated FROM wp_terms t LEFT JOIN wp_term_taxonomy tt ON (t.term_id = tt.term_id) LEFT JOIN wp_term_relationships tr ON (tt.term_taxonomy_id = tr.term_taxonomy_id) LEFT JOIN wp_links l ON (tr.object_id = l.link_id) LEFT JOIN wp_links_extrainfo le ON (l.link_id = le.link_id) WHERE tt.taxonomy = 'link_category' AND l.link_id is not NULL AND l.link_description not like '%LinkLibrary:AwaitingModeration:RemoveTextToApprove%'  AND l.link_visible != 'N' ORDER by  name ASC, l.link_name ASC-->
    
    <!-- Link Results: Array
    (
    )
    -->
    
    </p>

    Let me mark that I've tested the Mysql "Link Query:" query in a mysql shell within my 'wordpress' database, and I get the following error :

    SELECT distinct *, l.link_id as proper_link_id, UNIX_TIMESTAMP(l.link_updated) as link_date, IF (DATE_ADD(l.link_updated, INTERVAL 120 MINUTE) >= NOW(), 1,0) as recently_updated FROM wp_terms t LEFT JOIN wp_term_taxonomy tt ON (t.term_id = tt.term_id) LEFT JOIN wp_term_relationships tr ON (tt.term_taxonomy_id = tr.term_taxonomy_id) LEFT JOIN wp_linksl ON (tr.object_id = l.link_id) LEFT JOIN wp_links_extrainfo le ON (l.link_id = le.link_id) WHERE tt.taxonomy = 'link_category' AND l.link_id is not NULL AND l.link_description not like '%LinkLibrary:AwaitingModeration:RemoveTextToApprove%'  AND l.link_visible != 'N' ORDER by  name ASC, l.link_name ASC;
    ERROR 1146 (42S02): Table 'wordpress.wp_links_extrainfo' doesn't exist

    Here are my MySQL wordpress database tables for info:

    +-----------------------+
    | Tables_in_wordpress   |
    +-----------------------+
    | wp_commentmeta        |
    | wp_comments           |
    | wp_links              |
    | wp_options            |
    | wp_postmeta           |
    | wp_posts              |
    | wp_term_relationships |
    | wp_term_taxonomy      |
    | wp_terms              |
    | wp_usermeta           |
    | wp_users              |
    +-----------------------+

    Yannick, I'm ok to take some real-time gmail chat / phone / skype conversation with you this friday or on the week-end.
    I have sent you my e-mail=jabber contact as a Facebook message to you.

    Thanks for all,
    sincerely,

    Jonathan-David Schröder (in France)

  8. myselfhimself
    Member
    Posted 3 years ago #

    (I'm seeing the 'No links found' too).

  9. klein.aaron
    Member
    Posted 3 years ago #

    I am having the same issue. WP 3.1 with the plug-in version 4.9.3. I initally installed with the automated installer and then removed that entierly and uploaded via FTP with no difference. I have tired the deactivate and reactivate trick aswell. On my site when I visit the links page I see No Links found as well as a link for the category and I turned on the link counter so I see the two links I have setup. When I click on the category nothing happens. When I try to search one of the links nothing shows up.

    I enabled debug mode but I didn't see anything different about what appears on the page. I have also noted that aside from the thumbnail of the website other content enter in the Link Library - Additional Peramiters section of the link edit page do not seem to hold what is put in them. I have tried making a link a featured link and putting a large description in but after saving when I go back to edit the content is not there.

    http://www.hopechapelverona.org/?page_id=23

  10. Geet Jacobs
    Member
    Posted 3 years ago #

    Same issue for me, Version 4.9.3 WordPress 3.1

  11. myselfhimself
    Member
    Posted 3 years ago #

    In addition to "No links found" showing up instead of my links, as klein.aaron and Geet Jacobs: my category links are broken and point only to "#" (the click does nothing).

    jackdewey, thanks very much for your plugin. I hope to chat with you soon.

  12. Yannick Lefebvre
    Member
    Plugin Author

    Posted 3 years ago #

    Please try version 4.9.4 if you were a new user. I had a small bug in the table creation code for the links_extrainfo table.

  13. myselfhimself
    Member
    Posted 3 years ago #

    Thanks jackdewey ! it works again with 4.9.4 !
    Thank you very much for the remote assistance this morning !

  14. drperil
    Member
    Posted 3 years ago #

    Hey guys,
    I'm having this problem myself.
    I just updated the plugin to the current version (4.9.7) but still no links displaying. Granted I've only got one, but it shows 1 link under the category.

    Debug is on.

    http://wyodlc.org/apps-for-ed/

    Help :S
    ~ Flynn

  15. drperil
    Member
    Posted 3 years ago #

    nm, a complete delete and reinstall from repo fixed it.

  16. claudeg
    Member
    Posted 3 years ago #

    I had the same problem on a multisite installation. I desactivated the plugin on the network and activated it site by site. Now it works perfectly.

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic