WordPress.org

Ready to get started?Download WordPress

Forums

Link Library
Category Links Don't Work (11 posts)

  1. TheGraciousPantry
    Member
    Posted 3 years ago #

    I am running version 4.1.5.

    The list of categories displays just fine, but when you click the link, nothing happens. It simply "refreshes" the screan and says "error on page".

    Any advice? My readers depend on this list. I need to get it back up and running quick!

    blog: http://www.TheGraciousPantry.com.

    Thanks!
    Tiffany

  2. Yannick Lefebvre
    Member
    Plugin Author

    Posted 3 years ago #

    Hi Tiffany,

    Sorry for the trouble. Could you either:

    - Turn on debug mode on your Link Library installation so that I can get more information on your settings

    or

    - Give me temporary access to your wordpress admin so that I can go in and see what is happening with your list.

    What do your links normally point to? WordPress pages on your site?

    I am looking at the HTML and there is definitely something wrong.

    Yannick

  3. TheGraciousPantry
    Member
    Posted 3 years ago #

    Hi Yannick,

    The links point to tag categories and should bring up any recipes tagged with a particular ingredient (whichever one they have clicked on).

    Can you advise me on how to turn on the debug mode?

    Thanks
    Tiffany

  4. TheGraciousPantry
    Member
    Posted 3 years ago #

    Oops! Just figured it out. It's now in debug mode.

    Let me know what to do next.

    Thanks!
    Tiffany

  5. Yannick Lefebvre
    Member
    Plugin Author

    Posted 3 years ago #

    Hmm... how did you update to the latest version of Link Library? Did you use the automatic update? Did you you upload the plugin files manually?

    I think the main problem is that you have not re-saved your settings since you upgraded to the new version.

    That being said, things should still work even if you don't save settings anew. I just released version 4.1.6 which should address the issue. It should be available for download soon.

  6. fredriksoerlie
    Member
    Posted 3 years ago #

    I'm having the same problem I think. I only want to show a list of categories on the front page. It displays fine, but clicking the categories doesn't take me anywhere. The site in question is located at: http://ww2.folkesport.no

    I hope there is a simple solution to this and that I'm just stupid ;)

    Fredrik

  7. Yannick Lefebvre
    Member
    Plugin Author

    Posted 3 years ago #

    Hi Fredrik,

    If you only put the [link-library-cats] on the front page, then what you need to do is to have another page on your site that will have the [link-library] code to display the link list.

    Then, inside of the Link Library admin page, you would put the URL of that page in the "Category Target Address" field. Also, make sure that the switching method is set to HTML GET for this type of configuration.

    Let me know if this explanation makes sense.

  8. fredriksoerlie
    Member
    Posted 3 years ago #

    Thanks. Worked like a charm. However, is it still possible to show all the links on one page as well?

  9. Yannick Lefebvre
    Member
    Plugin Author

    Posted 3 years ago #

    So, you would want the category links on first page to go to second page and jump to right category within a full list?

  10. hippiegeek
    Member
    Posted 3 years ago #

    It appears the category link problem has reared it's ugly head again with WP 3.0.1 using LL 4.2.5. I've clicked stuff on and off for about an hour. I have debug mode turned on so if you get a chance to look at it on a site, go here under the "Sights" page: http://www.eyesonmemphis.com/ (the site is not finished as of this posting). I've set HTML GET, added a "category target address", the whole nine yards. Still can't get the category links to work.

  11. Yannick Lefebvre
    Member
    Plugin Author

    Posted 3 years ago #

    Sorry for the lack of response. I was very busy with Wordcamp Montreal last week-end and doing catchup since.

    I cannot see the Sights section on your site. It says that it's in maintenance mode. Can you take it off that mode so that I can see the page?

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic