WordPress.org

Ready to get started?Download WordPress

Forums

[resolved] [Plugin: Link Library] Can't exclude categories (7 posts)

  1. rardnek
    Member
    Posted 5 years ago #

    Hi, I just discovered your plugin and installed it today.

    I'm excited to use it, but am having trouble getting it to exclude certain categories in the page I'm using the Link Library in.

    On the Link Library settings page, I have entered the cat ids I want to exclude as:
    7,14
    ... yet they still appear in my Link Library page listing.

    I'm sure I have the cat ids correct, b/c in the Admin -> Link -> Link Categories page, I can hover over the cat name and see the url:

    /wp-admin/link-category.php?action=edit&cat_ID=7

    Yet these ids still show up.

    So then I tried to exclude on the page level. I updated the html on the page to look like this:

    [link-library-cats excludecategoryoverride="7,14"]
    [link-library excludecategoryoverride="7,14"]

    Yet the page is still displaying *every* category.

    Please advise.

    thanks,

    Kendra

  2. Yannick Lefebvre
    Member
    Posted 5 years ago #

    Hi Kendra,

    I just ran a quick test and was able to exclude one of my categories. A few questions: is it possible that you might have categories with the same name within your post categories AND your link categories? Are both the category name and the links within showing up or only the link category name?

    Yannick

  3. rardnek
    Member
    Posted 5 years ago #

    Hi Yannick,

    Thanks for the response.

    The categories I'm trying to exclude are unique to links - I do not have any post categories by the same name.

    The excluded categories are showing up both in the category name list as well as the full listing of links.

    For kicks, I tried setting the the "include only" option to these same fields. When I do that - my page listing only displays the above mentioned categories. Yet it does not seem to exclude them, when I cut and paste the same value in the exclude setting.

    Crazy!

  4. rardnek
    Member
    Posted 5 years ago #

    aha! I think I figured it out.

    I didn't realize it, but I had set the Results Order to "Order of categories based on included category list'. Which was blank for me. It seems like, based on it being blank, it was showing everything.

    When I changed that param to be something else (i.e. name), the excluded categories properly disappeared from my listing.

    So - there may be a bug with that field, but I've got things working for me now.

    Thanks!

  5. Yannick Lefebvre
    Member
    Posted 5 years ago #

    Indeed, there's a bug with the logic behind this ordering mode when the include field is empty. I will look into it in the next day or two and look at issuing an update. Thanks for digging through and isolating it so well.

  6. Yannick Lefebvre
    Member
    Posted 5 years ago #

    I was able to quickly correct the issue and release version 1.2.3. Let me know if you encounter anything else. Also, please make sure that you maek this issue as resolved.

  7. rardnek
    Member
    Posted 5 years ago #

    I just upgraded and it looks good. I tested it with setting the order by the (blank) include list, as well as by name.

    Tx for the quick fix!

    Kendra

Topic Closed

This topic has been closed to new replies.

About this Topic