WordPress.org

Ready to get started?Download WordPress

Forums

Lightview Plus
lighview-plus : Wrong path and missing files in version 2.5.3.1 (11 posts)

  1. petitnuage
    Member
    Posted 3 years ago #

    Once installed, the plugin uses references to files to be found in "css" and "js" subfolders. Those are missing in the "2.5.3.1" plugin version leading in 404 errors.

  2. puzich
    Member
    Plugin Author

    Posted 3 years ago #

    Have you ever read the installation instructions? I think not! Because you have to install the lightview javascript files manually due to license problems!

  3. petitnuage
    Member
    Posted 3 years ago #

    You're right, sorry. I've read everything now.

    There is another issue here: your plugin is based on proprietary code, since it cannot run without it. So, it cannot be distributed under GPL. And then, it cannot be hosted on WordPress.org.

  4. puzich
    Member
    Plugin Author

    Posted 3 years ago #

    I doesn't use any proprietary code in my plugin. That's it!

  5. Happy to Read You
    Member
    Posted 3 years ago #

    Hi Puzich! Happy New Year!

    Well, I have spent one full day trying to install Lightview Plus, have read all of the help reports I could find online, and now I must ask for your help! I hope you will be generous with it :-)

    -- I am getting a 404 error when I click the LV-P embedd button on edit posts/pages.

    -- I HAVE uploaded the Lightview folders: css, js and images to my Lightview-Plus folder on the host. ** My host would not allow me to upload the folders directly, so I uploaded the individual contents and then created folders on the host with the same names and put the contents back into them.

    -- I HAVE uploaded the scriptalocous files, because there were none in the LV-P download folder: ***These are currently not in folders on the host. They are single files currently in my top-level Lightview-plus folder along with the Lightview-plus js, php and popup.php files.

    So, my current host folder directory looks like this:

    ROOT
    WP-CONTENT
    WP-PLUGINS
    Lightview-plus
    >> (lightview folders): js, css, images
    >> (scriptalocous files): prototype.js, scriptaculous.js,
    builder.js, effects.js, dragdrop.js, slider.js,
    controls.js
    >> (lightview-plus files):
    lightview-plus.js, lightview-
    plus.php, lightview-plus-popup.php

    -- My LV-P General Settings are set to: no, no, yes, yes, yes

    -- I have NOT included this is my theme head <?php wp_head(); ?>, because I just don't know how to do that. Do I do this in the WordPress Appearance editor?

    Please, Puzich--I would appreciate some assistance, and I will donate to all the plug-in authors whose products I have used once my site is complete. Thank you so much and viel Spass!

  6. puzich
    Member
    Plugin Author

    Posted 3 years ago #

    You wrote, that the scriptaculous files are not in the lvp zip folder and you have 404 errors. I think, you have to download and re-upload it again, because they are there.

    And you wrote, that you can't upload folders to your host? Best answer for this is, to change you host!

  7. Happy to Read You
    Member
    Posted 3 years ago #

    Hi Puzich! Thanks so much for responding.

    I have actually downloaded-installed-uninstalled a total of 5 times. I also always went into the host to assure all files were deleted before installing again. So, if the scriptalicious files are there, then something else is wrong.

    Maybe I need to change hosts. But in the meantime, it should be ok to upload the Lightview files individually and then put them into folders I create called js, css, and images, yes? If the answer is yes, then something else is wrong.

    I have been to your site, I have read all the literature out there about this. Something is still not working. Are you able to provide a bit more assistance? If not, I will move on and forget the plug-in. I would love to use it, but 2-1/2 days spent trying seems like enough.

    Thanks so much and best wishes!

  8. Happy to Read You
    Member
    Posted 3 years ago #

    Ok, I have done another install. This time as a direct upload instead of the automatic install through WP. And, my folders and files are all as they should be, and the scriptalocous and prototype files are also there, where they should be.

    So, Puzich, the last thing is-- can you please tell me where in the code I should place this: <?php wp_head(); ?>

    If this last attempt does not work, I am going to give up :-)

    I hope it works!!!

    Best wishes,
    S.

  9. puzich
    Member
    Plugin Author

    Posted 3 years ago #

    You have to add wp_head(); into your theme into the header.php between the head-tags. But don't add it twice

  10. Happy to Read You
    Member
    Posted 3 years ago #

    Hi Puzich. Thanks for helping me. I still have not gotten this to work, but will come back to it and try again after I get a couple of other things up--like my content! :-D I'll let you know how it goes and donate if & when I manage to get it up and running. It is an elegant little feature. Cheers!

  11. rasmuskarlsen
    Member
    Posted 3 years ago #

    I'm running latest wordpress + NExtgen gallery latest. Cannot get this to work either :/ Nothing happens when clicking the images. It only opens the images the normal way (Open in the same window) No popup or anything.. :/

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic