WordPress.org

Ready to get started?Download WordPress

Forums

Lightbox Plus Colorbox
[Plugin: Lightbox Plus] conflict with Transposh Translation (3 posts)

  1. wp.Man
    Member
    Posted 3 years ago #

    i have contacted the Transposh dev

    Fatal error: Cannot redeclare file_get_html() (previously declared in /home/byte/public_html/wp/wp-content/plugins/transposh-translation-filter-for-wordpress/core/shd/simple_html_dom.php:39) in /home/byte/public_html/wp/wp-content/plugins/lightbox-plus/classes/shd.class.php on line 41

    http://wordpress.org/extend/plugins/lightbox-plus/

  2. Ofer Wald
    Member
    Posted 3 years ago #

    Assume you have two plugins, the two of which use the same library (simple_html_dom) and a conflict will happen, Transposh attempts to avoid this by not loading said library if it is already defined, so if it is loaded second,there will be no conflict.

    Your options are:
    1. remove the include/require for simple_html_dom from lightbox-plus
    2. fix the beginning of the code of simple_html_dom (see how it is done in Transposh)
    3. bug the plugin writer to do this upstream (#2)
    4. avoid using one of the plugins

    Good luck

  3. wp.Man
    Member
    Posted 3 years ago #

    thanks Ofer - hopefully the LBP dev will take care of this

    for others having the same problem, the simplest work around it is to enable LBP first, then Transposh

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic