WordPress.org

Ready to get started?Download WordPress

Forums

[Plugin: Lightbox Plus] Broken in Safari (12 posts)

  1. sterlingokura
    Member
    Posted 5 years ago #

    The latest plugin version 1.5.2 looks great. Love the different style options.

    Unfortunately it covers up the entire browser with black or white (depending on style) in Safari. Seems fine in FF, IE, & Chrome.

    Have verified with several different blogs w/ different themes on either WP 2.7.1 or 2.8.

  2. Dan Zappone
    Member
    Posted 5 years ago #

    Hmm... I'm not seeing that issue but I will continue to try to replicate it. What version of Safari? Windows or Mac or both?

    Edit: could there any other JavaScript that might me interfering. I haven't tried it again on Safari on a Mac today (don't have my MacBook with me) but Safari 3/4 on Windows seems to work fine for me.

    Click the screenshot on: http://www.23systems.net/plugins/lightbox-plus/

  3. serhanbuy
    Member
    Posted 5 years ago #

    Hi,
    Unfortunately I had the same problem. I had to remove the plugin, since it completely prevents the users from seeing the page.
    I have no other plugin installed, that puts other javascript inside my page, so lightbox plus was the only one.

    Hope you can solve the problem.

    P.S. I run Safari 4 on Vista

  4. babblelingo
    Member
    Posted 5 years ago #

    I run Safari 4 on WinXP and the activation of this plugin made the entire site disappear in that browser. Deactivate it, all is well. Other browsers (on my PCs) are fine with it so far... Opera, IE 7, Foxfire 3.5. I have no other javascript happening, just the usual PHP.

    If I knew how to tell WordPress -- IF Safari DO NOT load this plugin-- then I would do that, but I have no idea how. Any other work-arounds (or fixes) would be much appreciated!

  5. babblelingo
    Member
    Posted 5 years ago #

    duh... took a tad more research, but I finally realized it was because I had my wp-head() code AFTER my other style sheets were declared. I was cascading the wrong direction! So now Safari works, though I am struggling with how much smaller all my text-sizes are!!

  6. Zambrano Sergio
    Member
    Posted 5 years ago #

    I just tested both source codes for Safari and Firefox, and there's no difference in the code.

    It seems it's the black background cboxOverlay, but it's not a css issue since there's no transparency for that overlay on the loaded css file.

    It's not a transparency support either, since it happens even when images are disabled.

    It must be the original colorBox JavaScript, since when javascript is disabled, the page loads fine.

    It happens on Safari 3.23 and Latest version of Chrome.
    I'm restarting to install Safari 4

  7. babblelingo
    Member
    Posted 5 years ago #

    I spoke too soon... again I cannot see my pages in Safari 4 for PC. There is source code, so I know it's there! And turning off javascript in the browser does fix it.

    What could I be doing wrong? Here's the Heading section of code I get:

    <!DOCTYPE html PUBLIC "-//W3C//DTD XHTML 1.0 Strict//EN" "http://www.w3.org/TR/xhtml1/DTD/xhtml1-strict.dtd">
    <html xmlns="http://www.w3.org/1999/xhtml" dir="ltr" lang="en-US">
      <head>
    
    <meta name='robots' content='noindex,nofollow' />
    <link rel="EditURI" type="application/rsd+xml" title="RSD" href="http://anniefink.com/wordpress/xmlrpc.php?rsd" />
    <link rel="wlwmanifest" type="application/wlwmanifest+xml" href="http://anniefink.com/wordpress/wp-includes/wlwmanifest.xml" />
    <script type='text/javascript' src='http://anniefink.com/wordpress/wp-includes/js/jquery/jquery.js?ver=1.2.6'></script>
    <script type='text/javascript' src='http://anniefink.com/wordpress/wp-content/plugins/lightbox-plus/js/jquery.colorbox-min.js?ver=2.7.1'></script>
    <meta name="generator" content="WordPress 2.7.1" />
    
    <script type="text/javascript">
    jQuery(function($){
      $(document).ready(function(){
      $.fn.colorbox.settings.transition = "elastic";
      $.fn.colorbox.settings.speed = 350;
      $.fn.colorbox.settings.maxWidth = "90%";
      $.fn.colorbox.settings.maxHeight = "90%";
      $.fn.colorbox.settings.resize = true;
      $.fn.colorbox.settings.opacity = 0.85;
      $.fn.colorbox.settings.preloading = false;
      $.fn.colorbox.settings.current = "Image {current} of {total}";
      $.fn.colorbox.settings.previous = "previous";
      $.fn.colorbox.settings.next = "next";
      $.fn.colorbox.settings.close = "close";
      $.fn.colorbox.settings.overlayClose = false;
      $.fn.colorbox.settings.slideshow = true;
      $.fn.colorbox.settings.slideshowAuto = false;
      $.fn.colorbox.settings.slideshowSpeed = 500;
      $.fn.colorbox.settings.slideshowStart =  "start";
      $.fn.colorbox.settings.slideshowStop = "stop";
      $("a[rel*=lightbox]").colorbox();
      });
    });
    </script>
    <link rel="stylesheet" type="text/css" href="http://anniefink.com/wordpress/wp-content/plugins/lightbox-plus/css/lightweight/colorbox.css" media="screen" />
    
    <title>
      annie fink designs</title>
    
    <meta http-equiv="content-type" content="text/html; charset=UTF-8"> 
    
        <style type="text/css" media="screen">
          @import url( http://anniefink.com/wordpress/wp-content/themes/annie/style.css );
        </style>
    
        <link rel="pingback" href="http://anniefink.com/wordpress/xmlrpc.php" />
    
    <!--[if lte IE 7]>
    <style type="text/css">
    #content { padding-top: 160px; }
    </style>
    <![endif]--> 
    
      </head>

    Thanks!

  8. babblelingo
    Member
    Posted 5 years ago #

    Dang! Now I have installed and tested on Chrome, and the same exact problem!! Turned off Javascript, and it shows.

    Seems the background color of the BODY is all that shows up and is covering everything? This is in Safari 4 and in Chrome 2. The page is there, but covered? Javascript problem, or me? I am running WinXP Home SP2.

  9. vtroia
    Member
    Posted 5 years ago #

    Fixed with some simple CSS:

    #cboxOverlay { display:none; }

    cbox will still display properly afterwords.

  10. Dan Zappone
    Member
    Posted 4 years ago #

    That's just weird. I use Chrome extensively and haven't seen that. I've seen it in Opera though. I'll see if what can be done.

  11. Sheryl
    Member
    Posted 4 years ago #

    I just installed Lightbox Plus to the latest version of wordpress.

    Now what?? I want to create a clickable (right and left arrows) slideshow controlled by the reader in a single post with captions for each photo.

    Here is an example of what I want it to look like and function like:

    http://www.rachelzoe.com/excessorize-20-essential-accessories?utm_source=The+Zoe+Report&utm_campaign=b2a4624680-20_Guide_Accessories3_12_2010&utm_medium=email

    Thanks

    Sheryl

  12. cehwitham
    Member
    Posted 4 years ago #

    I can confirm that I had the same problem and that the above fix of adding;

    #cboxOverlay { display:none; }

    to my themes style.css file right at the end solved this problem and allowed all functionality to remain.

    Thank you vtroia!

Topic Closed

This topic has been closed to new replies.

About this Topic